Funny bug and how to report it

I admit I’m a Linux beginner or a newbie. I have started using Linux a couple a months ago. I have found a bug but I don’t know how to report it. It’s a bit of a funny bug because it does not cause any harm but not the less I would like to report it. Here is the description:

  1. I use to disconnect my computer during summer when heavy storms with lightning occur.
  2. Everytime I reconnect my computer to power and ethernet after the storm has stopped, the screen with the disk encyption password field fails to load: I cannot type the disk encryption password. The screen is blank.
  3. When this happens I just reset the computer by pressing the reset button on my computer case and everything works as usual.

Thanks for your advice.

1 Like

Dear Mitja,
welcome to the Ask Fedora forum.

The process of how to report a bug is documented here:

Have you tried pressing ESC to see what might be going on in the background?

What graphics adapter does your computer have?

Have you had a look at the log files?
Especially journalctl -o short-precise -k -b -1 and journalctl -b -1 may show you what went wrong during the previous boot attempt

1 Like

I tried, Esc, typing the password despite the screen was blank (my password is quite simple and I’m quite good at typing), but the only solution is to press the reset button and then Fedora 34 works as expected.


As I said I’m just a Linux newbie using Linux for a couple of months. I don’t know the commands you suggested me. I can send the output of the Journalctl command if needed, but I’m unable to troubleshoot it.

My hardware is
Intel i5-3550 processor
Samsung 840 SSD
WD Black 1 TB HDD
8 Gb (2*4 GB 1666 DDR3)
AMD Rx480

we can try to go through it together. First, reproduce the bug, then reset the computer and boot your machine up, then run journalctl -o short-precise -k -b -1 , paste the output in and share a link here. for j ‘journalctl -b -1’ command
SUSE Paste for ‘journalctl -o short-precise -k -b -1’ command

Just curious, can your computer suspend and wake up again (from power button menu on Fedora Linux)?

There are known problem on some AMD gpu can not wake up properly (the system already wake up but only main display didn’t) after suspend.

Computer can suspend fine. This is a software problem. Here are the steps to repro:

  1. Turn off computer in case it isn’t already turned off. Unplug power cable from power.
  2. Plug the power cable.
  3. Turn on the computer. The computer turns on correctly, I can see the splash screen and I can enter the UEFI if I wanted to.
  4. Fedora 34 starts loading, but when the full disk encryption screen is supposed to show nothing happens, the screen is black and the password cannot be entered. Typing the password does not work.
  5. Press the reset button on the computer case and the computer resets and boots OS normally, displaying the full disk encryption password screen.
avg 19 23:29:13.950045 fedora kernel: Lockdown: systemd-logind: hibernation is restricted; see man kernel_lockdown.7
avg 19 23:29:14.179043 fedora kernel: rfkill: input handler disabled
avg 19 23:29:18.152076 fedora kernel: logitech-hidpp-device 0003:046D:101B.0004: HID++ 1.0 device connected.
avg 19 23:29:20.373064 fedora kernel: Lockdown: systemd-logind: hibernation is restricted; see man kernel_lockdown.7

I’m not sure, but I believe Fedora by default hibernate not enabled. Did you enable it?

Edit: Because from your journalctl mention about hibernation.

If not, please check if your power button are currently set to hibernate. If yes, disable by set it to do nothing or set it to sleep or power off.

Also please send result of this command:

$ sudo grubby --info=ALL