Front left and right speakers (5.1) not working

Since about halfway F33 my audio stopped working correctly. I suppose it’s a kernel thing, but not sure. When I boot a F32 live USB then everything works fine. So the hardware is not at fault.

I was hoping that F34 would fix it somehow, because it now uses PipeWire for audio instead of PulseAudio or something? But the same error persists and my front left and right speakers don’t work.

I tried the usual stuff, alsamixer and pavucontrol. These usually fixed issues for me, but no update of the past month fixed it so far. So I’m reaching out to the community. I’m now using Analogue Stereo Output to have at least balanced sound, in that setup my rear left, right and front center speaker only work.

Do you also experience these issues?

Here is my system info: alsa-project.org/db/?f=b837be87549f851b4641a1bd8113d1855f18659b

I also tried the 5.12 kernel, but that didn’t fix it.

1 Like

A fresh reinstall fixed the issue :slight_smile:

1 Like

The problem came back again :frowning: Any troubleshooting advice? It’s not kernel related (booted the old one, no difference). I don’t know enough yet about PipeWire, but this also happened with F33, which still had PulseAudio as the default. rpmverify doesn’t show any sound related configuration changes. I also didn’t change anything, besides installing regular updates.

I assume you’ve tried unplugging, rebooting, replugging? or just a simple unplug, replug?

From what you describe, it sounds like you have the wires crossed between your “front surround” and “rear surround” outputs.

Last time this happened, the audio worked fine when booting from a live USB. I’ll check that this weekend as well. It will most probably be the same again. So this is most likely a software issue. But I’ll confirm this again ASAP.

Any other troubleshooting advice?

There is a post on Fedora’s User support forum where someone mentions using hdajackretask to do some fairly low-level pin reassignments.

I haven’t used the software personally. I don’t really know if it is the right tool for the problem you are having. But it might be something to consider. If you have trouble with it, you might be able to start a thread on that forum and mention “unamused” to get his attention.

Edit: I just noticed that your device is using the snd_virtuoso driver. I think hdajackreset is designed specifically for cards that use the hda driver. So it probably won’t work.

Does anyone know how I can do a hard reset of the audio settings in Fedora? Removing ~/.config/pipewire doesn’t do anything. Things keep in a quantum state. Now sometimes I have to use the 4.0 setting to get sound, which then makes movies a bit strange, because the voice channel is then muted (center speaker).

A clean install will fix it of course, but that’s not really a fix.

Does the following do what you want?

systemctl --user restart pipewire.service

I’m afraid not. It has no effect. For some reason the “analogue devices” pile up in the GNOME settings menu as well. So deleting those configs doesn’t do the trick. Resetting dconf doesn’t make a difference either. There is something keeping these configs, but can’t figure out what. I guess I’ll just reinstall this weekend again. Life is too short for this.

In retrospect it might be hardware error I tried to boot from USB and I got the same problem. It might be a faulty audio card or maybe the power supply is too old