Fonts look off on new system? (Fedora 34 KDE)

I recently installed Fedora 34 KDE, having employed Manjaro and Solus in the past. I like it so far (after getting acquainted with selinux anyway) what with being able to use color profiles and having G-sync working without my desktop flickering even with the OpenGL 3 compositor.

Something I haven’t been able to work out though is why most fonts in most settings/ webpages/applications look, well, bad. Like low-res versions of their real selves. Sometimes almost like normal and sometimes pretty noticably off and occasionally with purple/pink halos.
Under system settings-fonts I’ve changed the default sizes to +1, but not changed the fonts themselves. RGB antialiasing is on by default and if I turned that off most fonts look downright horrible.

Have never experienced anything like this and since the system settings → fonts appear to be able to influence the fonts globally I’m wondering if I’m missing something?

I’m using the OpenGL 3 compositor if that helps, have a Nvidia RTX 2060 graphics card and a 1440p display. (Am also using X11 which the install defaulted to. Tried Wayland and Kitty lost its background translucense and the first native linux Steam game I tried to launch failed spectacularly in a graphical-glitch way so I reverted to X11).

Just to verify I compared a few specific bits of webpages in Firefox in Win10, a later version of Gnome 3 (40) and a live Manjaro KDE of the latest version…the Manjaro KDE environment had precisely the same problem (the other two did not) so that led me to believe it might be a KDE issue. I found KDE does not render fonts like Ubuntu. How to Fix it? • KDE Community Forums and that, creating a .fonts.conf file and populating it like mentioned and then relogging has actually seemed to have made a difference for the better : )

1 Like

You said you have an nvidia GPU, but did not say whether you installed the nvidia drivers nor where you got them.

If you did not install them this link is an easy way to do it and it works very well with fedora. Maybe it is only a driver issue some see when using the default open source nouveau drivers. After the install reboot and see if there is a difference.

If you did install them and got them from some source other than the rpmfusion repo then I suggest you uninstall them and reinstall using the info in the above link to do a clean install. Then reboot and see if that helps.

I there. I installed the nvidia driver via the rpmfusion repo like so:

sudo dnf install$(rpm -E %fedora).noarch.rpm
ora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm
sudo dnf install akmod-nvidia

Have not investigated why the solution I found detailed in my previous post works but it does.

1 Like