Font rendering bug. All characters in system programs are rendered as hexadecimal boxes

After upgrade to Fedora 34 i have this problem:

Things I’ve tried: refresh font cache, change permissions on font files, check if liberation fonts installed.
The interesting thing is that in region and language settings menu i have all languages rendered as boxes, but Asian hieroglyphs are rendered normal.


Hi @ordekonec welcome to the forum. Please take a minute to go over the introductory posts in the #start-here category if you’ve not had a chance.

Are you using any extensions? Can you please disable them, log out and back in to see if it works. As an even better check—can you please create a new user and see if the issue persists?


Hello, ty for reply. I’ve tried new user and the problem disappeared. But i can’t fix it on main user, I’ve already installed language packs but it still showing me boxes

1 Like

So when I upgraded from 33 I had this same problem. I was however in KDE not GNOME. I ended up resolving it by resetting my system fonts to default, and removing the following folders:


both of these folders are from a legacy configuration and have been moved in current versions of Fedora so if you have them you should erase them. Hope that helps :slight_smile:


Yours and mine hope is resolved). Thank you for reply and help. This is the solution

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.