Flatpak not working on Asahi

I tried to install packages using Flatpak, and it turned out that no packages can be found. For example, this happened when I tried to install Signal desktop:

$ flatpak install flathub org.signal.Signal
Looking for matches…
error: Nothing matches org.signal.Signal in remote flathub

Flatpak should be working out of the box on fedora. I also tried $ flatpak remote-add --if-not-exists flathub https://dl.flathub.org/repo/flathub.flatpakrepo. Nothing has fixed the problem yet. Does anyone have the same issue?

Signal desktop is only available for x86_64 on Flathub. See “Available Architectures” on the packages Flathub page. Only packages with “aarch64” will be available.

For Signal Desktop,
someone already got a build of this package working in COPR for aarch64 :tada:

(and there is also already a longer running request for this for the Flatpak)

1 Like

Also, if you’re unable to see other flatpaks from flathub for aarch64 after adding flathub (e.g., gimp), you may have to run flatpak remote-modify --enable flathub

Hi, i am having problem to install flatpaks on Asashi Fedora Remix also. For example, i am able to install Bitwarden which is aarch64 architecture but does not open at all. Brave browsers intalls, but crashes on open.

I am on a M1 mac, anyone has any idea? Im I doing anything wrong?

Thank you!