First real world ostree win for me! The toolbox too!

I love sway and wanted a newer version. I committed to building it from source and I decided to use the fedora toolbox to avoid issues on my host OS. Everything worked great. I installed way more random packages than I would have liked and didn’t have to care because it’s a container. I got sway built and when I finished I tried running ing sway from the virtual console. It was spewing errors about some missi g library. I installed the library using RPM-ostree. It was late so when it finished and I got sway up I just closed the laptop lid.the batter died over night and when I powered the laptop up it was not coming up. I tried the normal troubleshooting procedures to no avail. Then I remembered… :thinking: I’m using ostree, how do I just use an earlier revision? I realized the normal boot loader menu had my revisions. I loaded up a previos version and… BOOM… I was back in buisness.

Thanks SilverBlue.

7 Likes

That’s great! Just in case, I’d recommend running an fsck on your partition afterwards, as ext4 doesn’t always handle abrupt shutoffs too well.

Xfs for win! I checked it :wink:

1 Like

Haha nice, I’ve got to try that next install.

Thanks for sharing with the rest of us!

Had that, but really regretted that later, when I needed to shrink the partition. ¯\_(ツ)_/¯