Firefox sticks do AMD iGPU, refuses to use Nvidia dGPU

Hi all,

I have a AMD Renoir iGPU, and a GTX 1650 Nvidia dGPU. Latest Nvidia drivers from RPMFusion are installed. I even tried to setup PRIME using the nvuautoinstall script, which apparently ran without any issues.

Still, Firefox’s about:support tells me this:

If I run Firefox with DRI_PRIME=1, it changes to this:


It doesn’t seem quite right, I was expecting to see the GTX 1650 as the active GPU #1.

Any hints on what is wrong, and how to make this work? I am on a crusade to enable hardware video decoding on Firefox, and this seems to be the first obstacle.

In my experience the steps shown in this doc work to make the nvidia the primary gpu.
What it does not state is that solution only works when using the xorg DE. The user must log in with xorg then the nvidia gpu is alwasy used.

The user must also already have the nvidia drivers loaded since it seems the nouveau drivers do not support hardware acceleration on nvidia gpus. How to install the nvidia drivers and cuda support is shown here.\bCategoryHowto\b)

Hi @computersavvy !

Yes, that’s what I was afraid of: this seems to only work for X11. I am using Wayland, and don’t want to switch back to X11. BTW I am using NVidia proprietary drivers from RPMFusion.

I tried to follow these instructions as well, but I guess they don’t apply to iGPU + dGPU setups :cry:


Did you execute sudo nvautoinstall primec[1]? This command should enable the PRIME Configuration for your discrete GPUs to be used by all the applications regardless of your choice.

Alternatively, please select the GPU of your choice that you wish to run your applications on by RIGHT-CLICKING on the application from the launcher and selecting the discrete GPU.

  1. Please note that this is only confirmed to be working on Fedora Workstation so please be sure to take backups before you run this command. ↩︎

Also, I just assumed that you are using a laptop device but it does not hurt to confirm it again.

Are you, @ocosta?

Hi @t0xic0der , thanks for jumping in!

Yes, I did. But even though it reported success, it was not clear to me if it is supposed to work with Wayland or with X11 only.

I also tried this, but Firefox was unable to render properly, I could only see the windows’ frames, as if they were completely transparent. I will do some more testing, removing some environment variables changes I’ve made to see if I can get any further.

Yes, this is a Acer Nitro 5 AN515-44.

Hi @ocosta,

It is supposed to work with X11 only. To that extent, when that setting is applied - the Wayland option is removed to note the fact that the PRIME configuration is not supported on it[1].

This is interesting. Can you try doing this with any other application (like a videogame or an emulator) that can report what graphics device is made use of? It would be helpful to confirm if at all that context menu option is indeed taking effect to select your desired device of choice.

Thanks for confirming that it is indeed a laptop that you are using.

  1. Or at least, it used to be like that back in Fedora Linux when I tried back in the day. I am not sure if things have changed recently as I no longer have a laptop with a dedicated NVIDIA discrete GPU to test things on. ↩︎

Hi @t0xic0der ,

I don’t have any installed, but I will try ASAP, thanks for the suggestion.

BTW someone pointed on the thread I started on Nvidia Linux forum that I was using the wrong env var to offload to Nvidia card, the correct way is __NV_PRIME_RENDER_OFFLOAD=1.

Also, a quick update: by unsetting these vars


And by following these instructions for AMD, Firefox is capable of doing hardware video decoding for VP9 and H264 through Renoir (no VP8 or AV1, though). This is not what I was aiming for, but it is certainly good enough for the time being.