File copy issue while home to another ext4 drive error happens


can not copy or paste files to linux partition in kde with dolphin

Have you looked at the permissions of /media/insas/fa…3f to see if your user has ownership and write permissions? That is the first step to check.

1 Like

Yes it have permission

Can we see the output of ls -ld /media/insas/fa3* and mount | grep insas

These two are separate commands. But even from that output it appears that the mounted folder is under root:root ownership. Which would definitely explain permissions issue.

Why is this happening it’s hard to tell. I’ve had the similar issues on KDE in the past, but that was almost always when using ntfs formatted drive.

Perhaps someone more experienced with KDE from the community can share his experience and perhaps a solution, or a bug can be reported.

In any case, output of that mount command would be beneficial as well.

Yes i have one ntfs drive but when i am copying files from ext4 to btrfs or ext4 same error happens

What happens when you umount a drive and then mount it again manually via Dolphin? Selecting it in the sidebar should prompt mount action again.

Same problem but the problem has started after i create a drive with luks and btrfs but then i have deleted that drive and again reformated with ext4 but problem haven’t been resolved yet.

I guess permissions of the parent folder got changed somehow. Not sure what exactly is going on and how to reproduce the issue, as I’m Workstation edition user so sorry that I’m just hypothesizing.

I would try to unmount everything within that /media/USERNAME folder and then change permissions back or recreate the folder.

/media folder on my machine has dr-xr-xr-x. 1 root root permissions, and I don’t have the child folder holding my name. GNOME usually mounts those things in /run/media and there I would see something like:

ls -alh /run/media/ivan/
total 48K
drwxr-x---+ 4 root root  80 Nov  7 12:16 .
drwxr-xr-x. 3 root root  60 Nov  7 12:16 ..
drwxr-xr-x. 3 ivan ivan 32K Nov  7 12:16 liveusb
drwxr-xr-x. 7 ivan ivan 16K Jan  1  1970 VTOYEFI

So if the thing worked for you normally before, I’d suspect something has gone wrong with the parent folder permissions. In any case it would be good to open up a bug report and see what happens (and check if there are similar issues beforehand).

Yes this happen after my drive encryption

I had a similar problem more than once. It seems that sometimes fedora mounts previously unmounted devices as root ownership.

The fix I have used is relatively simple and only needs done once.

sudo chown user:user /run/media/user/mountpoint

Once that is done the first time then every time it mounts again it retains the new ownership and things work as expected for me.

I can only think that something in udev is not quite right since it would seem that anything mounted under /run/media/user/ should be owned by user.


isnt working

You have to replace mountpoint with your actual mount point.

Ohh i am sorry

I guess I assumed you would interpret that instead of needing led by the hand as you typed.

Sorry😔 i didn’t notice but i should have

I saw that chown is not found showing but now i saw that problem has been resolved i can now copy paste files here to there no issues.

Btw thanks