Fedora works slow after installing Nvidia drivers

Hi! After installing fedora 36 on default drivers it worked well. But Fedora didn’t identify my nvidia gpu thath’s why installed nvidia drivers according to instruction. Howto/NVIDIA - RPM Fusion. But after reboot system works slow. I tried to switch to xorg session, but it still the same.

lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation TU117M [GeForce GTX 1650 Mobile / Max-Q] (rev a1)
05:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Picasso/Raven 2 [Radeon Vega Series / Radeon Vega Mobile Series] (rev c2)

Please post the output of inxi -Fzx ane lsmod | grep -iE 'nouveau|nvidia' so we can see if the drivers are loading and the actual GPU in use.

inxi -Fzx
  Kernel: 5.18.11-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36 Desktop: GNOME v: 42.3.1
    Distro: Fedora release 36 (Thirty Six)
  Type: Laptop System: ASUSTeK product: TUF Gaming FX505DT_FX505DT v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: FX505DT v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: FX505DT.316 date: 01/28/2021
  ID-1: BAT0 charge: 36.3 Wh (100.0%) condition: 36.3/48.3 Wh (75.1%)
    volts: 13.0 min: 11.4 model: FX50442 status: full
  Info: quad core model: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx
    bits: 64 type: MT MCP arch: Zen/Zen+ note: check rev: 1 cache: L1: 384 KiB
    L2: 2 MiB L3: 4 MiB
  Speed (MHz): avg: 1388 high: 2064 min/max: 1400/2100 boost: enabled
    cores: 1: 1230 2: 1230 3: 1487 4: 2064 5: 1225 6: 1230 7: 1328 8: 1310
    bogomips: 33535
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: ASUSTeK
    driver: nvidia v: 515.57 arch: Turing bus-ID: 01:00.0
  Device-2: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
    vendor: ASUSTeK driver: amdgpu v: kernel arch: GCN 5 bus-ID: 05:00.0
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 3-1:2
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.3 driver: X:
    loaded: amdgpu,nvidia unloaded: fbdev,modesetting,nouveau,vesa gpu: amdgpu
    resolution: 1920x1080~60Hz
  OpenGL: renderer: NVIDIA GeForce GTX 1650/PCIe/SSE2
    v: 4.6.0 NVIDIA 515.57 direct render: Yes
  Device-1: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 01:00.1
  Device-2: AMD Family 17h/19h HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 05:00.6
  Sound Server-1: ALSA v: k5.18.11-200.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.55 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8169 v: kernel port: e000 bus-ID: 02:00.0
  IF: enp2s0 state: down mac: <filter>
  Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    vendor: AzureWave driver: rtw_8821ce v: N/A port: d000 bus-ID: 04:00.0
  IF: wlp4s0 state: up mac: <filter>
  Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-4:3
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 447.13 GiB used: 30.65 GiB (6.9%)
  ID-1: /dev/nvme0n1 vendor: Apacer model: AS2280P4 480GB size: 447.13 GiB
    temp: 21.9 C
  ID-1: / size: 445.54 GiB used: 30.41 GiB (6.8%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-2: /boot size: 973.4 MiB used: 231.6 MiB (23.8%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 14 MiB (2.3%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 445.54 GiB used: 30.41 GiB (6.8%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-1: swap-1 type: zram size: 7.46 GiB used: 14 MiB (0.2%) dev: /dev/zram0
  System Temperatures: cpu: N/A mobo: N/A
  Fan Speeds (RPM): cpu: 3200
  GPU: device: nvidia screen: :0.0 temp: 49 C device: amdgpu temp: 65.0 C
  Processes: 612 Uptime: 45m Memory: 7.46 GiB used: 2.87 GiB (38.5%)
  Init: systemd target: graphical (5) Compilers: gcc: 12.1.1 Packages: 10
  note: see --pkg Shell: Bash v: 5.1.16 inxi: 3.3.19
lsmod | grep -iE 'nouveau|nvidia'
nvidia_drm             73728  11
nvidia_modeset       1146880  13 nvidia_drm
nvidia_uvm           1286144  0
nvidia              40837120  641 nvidia_uvm,nvidia_modeset

The nvidia drivers are definitely loaded and functioning.

Please try copying the nvidia.conf file in so X11 can use it then reboot and log in using xorg to see if that makes a difference.
sudo cp /usr/share/X11/xorg.conf.d/nvidia.conf /etc/X11/xorg.conf.d/

I already did it.

cat /etc/X11/xorg.conf.d/nvidia.conf 
#This file is provided by xorg-x11-drv-nvidia
#Do not edit

Section "OutputClass"
	Identifier "nvidia"
	MatchDriver "nvidia-drm"
	Driver "nvidia"
	Option "AllowEmptyInitialConfiguration"
	Option "SLI" "Auto"
	Option "BaseMosaic" "on"
	Option "PrimaryGPU" "yes"	

Section "ServerLayout"
	Identifier "layout"
	Option "AllowNVIDIAGPUScreens"

P.S - I followed this instruction

There is one thing I have that is different in that file.
I added the ‘Option “PrimaryGPU” “yes”’ to both the ServerLayout and the OutputClass sections.

I do not however have your nvidia/amd combo but instead have an intel/nvidia combo.

The nvidia GPU will only be seen as primary when xorg is used as the DM (logged in using xorg). It also can only use hardware acceleration when running under xorg.

If not using hardware acceleration the graphics slows down because of software rendering.