Fedora v38 KDE ISO fails to load in virtualbox

I’m trying to install Fedora 38 KDE into a Virtual Box VM. However, when I attempt to boot the VM I get some lines of text from UEFI interactive shell and I’m left at “Shell>” prompt. The ISO has been downloaded and verified twice. I have Enable EFI checked in the settings. If I uncheck this setting then when booting the VM I get a pop-up window indicating that the virtual machine failed to boot. It sayss this is probably caused by a missing operating system or misconfigured boot order (the boot order is correct). It goes on to say that mounting an OS install DVD might solve the problem.

I later downloaded the Fedora 38 Workstation (Gnome), verified it, and attached it to the VM. When booting the Workstation ISO it boots normally to the Grub menu. Is there something special I need to do with Fedora 38 KDE? Is there something wrong with the KDE ISO? I do not want to install the Gnome edition right now. I want to install and test the KDE edition.

I’m using Virtual Box 7.0. I gave the VM:

  • 4 CPUs
  • 8192M RAM
  • 40GB pre-allocated storage space
  • 128M Video Memory
  • 1 monitor
  • Its set to Linux, Fedora 64 bit

I just tested this, and live system, install, and booting the installed vm works fine.
My host is Fedora 38, virtualbox is Version 7.0.8 r156879 (Qt5.15.10) (from Oracle repo).

Fedora KDE guest is a default installation with EFI enabled (secure boot disabled) in the virtualbox settings for that machine.

FYI, you can’t switch forth and back, you need to decide before you even boot the install media and then never touch the setting again.

Is your host Fedora or GNU Linux as well?

The first thing to do now is have a look at the VirtualBox logs and see it says there!

I’m running Manjaro v22.0.0 as the host. I haven’t run updates yet. I will run updates which will update Virtualbox and then re-attempt installation. Thank you.

I’m now running Virtualbox v7.0.8 r156879. Host is Manjaro KDE v23.0.0 with a 6.1.31-2-MANJARO kernel. I deleted the old VM (all files) and created a new VM.

The VM is set as follows:

  • Linux
  • Fedora 64bit
  • 8192MB RAM
  • 4 Processors
  • Boot Order = Optical Disk, Hard disk
  • EFI = enabled
  • Acceleration = Nested Paging, KVM Paravirtualization
  • 128M video memory
  • VMSVGA graphics controller
  • 40GB virtual disk
  • Fedora-KDE-Live-aarch64-38-1.6.iso attached to optical disk
  • Network = NAT

When I boot the VM I get a pop-up window:

it is as though there is no optical disk attached. If I click cancel I’m able to get the BIOS/UEFI boot menu. If I select the optical disk from the boot menu there is a short flicker as the VM tries to access/boot from that selection and I’m left at the boot menu. This is very strange.

I have the Fedora KDE v37 ISO file, which is named differently (Fedora-KDE-Live-x86_64-37-1.7.iso). When I attach it to the VM and boot. I get to the Grub menu. There is something strange going on with the v38 KDE ISO.

That’s the wrong iso image. You need the AMD64 image for x86_64 architecture

Download: https://download.fedoraproject.org/pub/fedora/linux/releases/38/Spins/x86_64/iso/Fedora-KDE-Live-x86_64-38-1.6.iso

1 Like

Oh man… how did I miss that. Queue the memes LoL. Let me go down load the correct ISO.


The correct KDE v38 ISO was downloaded, verified and is going through the install now.