Can't start after first update on a fresh install

Apologies for the lack of detail, but I’m not clear if there’s any kind of log I can share at this point.

I have successfully installed and run Fedora on this setup before. The problem seems to be with a new install (although I no longer have a functioning Fedora VM on this machine and so cannot test on an alternative).

I create a VM on Hyper-V (Generation 2 but I have tried with Generation 1) and load from the Fedora 38 Workstation iso. Fedora successfully loads from the .iso and installs. I am able to boot Fedora from this install without any issues.

The problem emerges after the updates are applied, either through directly updating through DNF or letting the Software Center update Fedora. After applying the update Fedora fails to load (it is effectively a blank screen). This has persisted over multiple attempts changing what settings I could.

Happy to post any specs/settings, but I’m not sure what is pertinent.


Added Detail:

This echos the problem that prompted me to make a new VM in the first place (an update that seemed to render the VM useless), but in this case it is isolated to a fresh install and the default behaviour of Fedora when loading (so far as I can tell I cannot stop it from downloading and advising of the critical software updates, nor would I want it to avoid doing these updates).

The only other variation I can think of would be that I enable the 3rd party repositories but disable and remove PyCharm and Google Chrome (it is also likely I’ve tried one where they aren’t removed).

So far as I can tell this is directly tied to the update, possibly the Kernel, but I’m lost as to what I can do differently beyond not performing any updates.

Try updating only the kernel. Does that break it?
If so try updating all but the kernel, does that work?

My suspicion is that it is the kernel that breaks it. The ‘critical update’ (or upgrade through DNF) includes the kernel.

Tey booting with the old kernel from grub, if you can.

I don’t mind trying this again, but what would once I load the old kernel?

If the old kernel works you know to report a bug against the new kernel.
Is that what you are asking?

I’m happy enough to submit a bug report, but it seems that if I am going to submit a report I should be much more specific than “the kernel isn’t working” and, of course, my hope would be that I would be able to use the machine myself.

I would provide information on the environment, Hyper V.
Which version of the kernel works and which fails.
Hopefully you get a response that will then take things forward.