Fedora Media Writer Restore USB not working

I recently installed Fedora 30 on a system, and I would like to reclaim the USB drive I used to install it. I have been running Fedora Media Writer and clicking the Restore button for the USB drive. However, the USB drive is not being recognized by Windows 10 once I finish.

I have tried several options to recover the drive. If I run the Computer Management tool and select the drive from Storage > Disk Management, I see the disk and its space. But if I try to Change Drive Letter and Paths, Windows 10 tells me “The system cannot find the file specified.” Attempting to format it gives me the same error.

Running diskpart as admin and attempting to “clean” the drive tells me that “Access is denied.”

If I run Fedora Media Writer again, it repeatedly gives me the option to Restore the USB drive.

Am I missing something?

You can use GNOME Disks to perform partitioning and formatting.

It was roundabout, but I was finally able to use GNOME Disks as part of the solution. I was able to format the drive for Windows from GNOME Disks, but my Windows 10 system still did not recognize it. However, I was able to run “clean” from diskpart, which then permitted me to set it up from the Disk Management tool.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.