Fedora Media Writer failure windows 11

Attempting to create USB drive of workstation 39 using fedora media writer 5.06 & 5.11.

Three different usb sticks, which work correctly in windows, all failed with the following error:

I tried running as administrator but it still failed.

Any advice would be appreciated.

Thank you

This is media writer on windows?
Did you download the iso then attempt to write it to the usb or are you trying to download and write it at the same time?

I always download the iso, verify that it is properly downloaded by using the checksum, tnen use media writer to write the iso to the usb device.

Thank you for your reply.
Yes it is media writer on windows 11
Yes I did download the ISO and am writing it from the HD
gpgv is not a valid windows command - so I was unable to follow the verification instructions

gpgv is a linux (fedora) command as noted. It is used to verify the gpg key signature on the CHECKSUM file and does not check the iso image at all.

The next step (step 4) is to verify the sha256sum of the iso and windows does enable that.

On my version of Windows 11 (pro) the following is reported:

“C:\Users\julian\Downloads>sha256sum -c Fedora-Workstation-39-1.5-x86_64-CHECKSUM
‘sha256sum’ is not recognized as an internal or external command,
operable program or batch file.”

I have found that the iso copies properly using other windows programs (iso to usb for example), however the docs warn that this is not the correct way to copy it.

A quick google search shows this

There are other apps to burn the iso to usb, most notably rufus

and balena etcher

Both have been highly recommended by many,

Thank you.

If it is not a problem using other apps, then since the ones I already have worked fine (powerISO created the bootable usb in about 2 mintues). I will continue with them.

I was concerned since the docs were clear that the tool was the only proper way to create the usb.
Thank you for responding

The docs are of course ‘fedora centric’ but I suggest you use what works for you since there are actually a lot of choices (some better than others)

On fedora I often use the dd command for that purpose.

Thank you again for the help. The os is now running without issue.

1 Like

Added fedora-media-writer

The error is saying that the target usb stick is write locked.
If there is not a write lock button on the usb stick I would guess the stick is faulty. Can windows format and copy files to the stick?

Do you have another to try with?

Also wonder if 4GiB stick is too small, I have been using 8GiB sticks for install for a long time.

Microsoft provide a powershell command to do file hashes, see Get-FileHash (Microsoft.PowerShell.Utility) - PowerShell | Microsoft Learn

Thank you for responding.
The usb drive is not the lockable type, it has no lock button, and it is formatable in windows 11 pro. I also tried 2 other usb drives (one 32 GB and one 8 GB) they all were first formated in windows (FAT32) but failed with the same error when trying to copy fedora using the media writer. I also tried a second computer (also windows 11 but the home edition) on the 3 drives with exactly the same results.

Ultimately I used the 4 GB drive with a windows iso-to-usb program and it worked perfectly, so I must concluded there is some issue with the fedora media write app and (my?) windows 11 on both computers.

Nevertherless it was resolved but not using the provided utility and resorting to a standard iso to usb writer. (in this case PowerISO, which I would have used in the first place had the docs not warned against using any writer but theirs)

Hopefully others with the problem will see this post and realize that using other iso-to-usb programs will not result in any issues.

Windows is making drive locked and failed on checking the iso on installation when using select iso on files, but when using download automatically and write all goes as should on Fedora media writer I have issued this many times and only way is to use media writer on Windows to flash fedora is just download automatically.

Somehow the USB is locked write protected still and it needs to be restored using again media writer restore option

Ah, that would explain it.

Still the other tool did the job quit effectively without media writer


With all this discussion I would strongly suggest that you file a bug report against the fedora media writer, windows 11 version. It should be able to write the iso to the usb device properly.