Fedora Live version should be more i8n frendly and less en_US / Eastern centric

Hi all !

Upcoming Fedora Linux 41 Live will Modernize the live media by switching to the “new” live environment setup scripts.

It would be a great opportunity to empower Fedora Live versions with more Internationalization and localization.

Currently the live environment is en_US / Eastern centric and is hardcoded in the scripts with:

  • Time zone: US/Eastern (EDT, -0400)
  • en_US keyboard layout
  • en_US locale

Could it be possible when the Desktop Environment is launched (e.g.) GNOME, to have a pop-up Internationalization and localization screen that asks for locale. It could be included in Gnome Welcome/Tour for example.

This would trigger the right Date/Time zone, Locale, Language, and so on… alike the Anaconda welcome screen.

1 Like

This already exists in rawhide. Give it a try!

But unfortunately it’s not ready for stable Fedoras quite yet. We keep deferring it to future releases…

Hi @catanzaro ! Thanks for the tip !

I gave it I try on Rawhide 202416.06. … and I like it !

I’ve tried to understand what program runs this under the hood and it is AFAIK powered by:

  • gnome-initial-setup (see it’s Readme.md)
  • which is also accessible within CLI: /usr/libexec/gnome-initial-setup --live-user

Some feedback:

  1. gnome-initial-setup smoothly allows for Internationalization on:
  • Language
  • Keyboard

But TimeZone management is not proposed. And it should let us fixe the catch 22 Date/Time settings when Timezone is changed

For now I get the right local Date/Time (Europe Central Time) after autostart launching gnome-initial-setup … but it’s still on US / Eastern TimeZone !

Is there a command line or parameter tweek to set so that Language, Keyboard, Date/Time and Timezone can be set ?

  1. Mouse pointer remains HUGE when using some Gnome Apps:
  • Files (nautilus)
  • Gnome Text Editor
  • System Monitor
  • and so on…
  1. LibreOffice has a bug
  • First launch would have an English interface and requires Gnome Software to install a langpack for LibreOffice
  • Should one close LibreOffice and simply open it again… Et voilà ! Language interface is aligned with locale set previously by gnome-initial-setup

So what is missing ?.. It seems good enough to be included into Fedora 41, isn’t it ?!!

1 Like

Interesting; I just assumed all this time Fedora was that good at knowing my timezone and keyboard layouts without input :stuck_out_tongue:

  1. Try copying /usr/share/gnome-initial-setup/vendor.conf to /etc/gnome-initial-setup/vendor.conf, then remove “timezone” from the section at the top:
[live_user pages]
skip=privacy;timezone;software;goa;network;

We could prompt the user to select timezone here, but there isn’t any code to copy it to the installed system yet, and we’re trying to avoid asking the same question multiple times.

  1. No clue what’s wrong here. Is there an upstream bug report? It would probably need to be reported on the GTK issue tracker.

  2. Would need to be reported on the LibreOffice issue tracker.

It’s tied to the new anaconda version, which is currently deferred until Fedora 42 at the earliest.

1 Like

Caught my attention with :thinking:

Sparked interest in :bulb:

Interesting :bulb: :exclamation:

Where could we assist in testing these things ?