Fedora Account creation issues - report

Decide to report some weirdness I had to deal with creating a new Fedora Account. I’m on F36 KDE spin, using latest Firefox version. Hopefully this will help The Team to figure out what went wrong, and simplify account creation for new users.

Minor User Experience issues. I started my account creation from ask.fedoraproject homepage by hitting Sign Up, got redirected and page asked me to login, had to click sign up again. Registration process was fairly smooth, except it wasn’t immediately clear you’re not supposed to use Capital Letters. But I completed registration and activated my account through the Gmail Android App, created password, and logged out.

Major (primary) issue.
I proceeded to Log In through my Firefox desktop browser, where I initiated registration process and later intended to ask my OS related technical questions, only to be greeted with a Red Warning Message " Authentication token is no longer valid; new one required". I thought maybe I entered my password incorrectly, and tried again several times, but got the same old warning. I thought maybe I should login from my phone one more time, where I finalized the account creation, but was greeted by that same message. So I decided to contact site administrator and report my issue (expected contact information under login boxes, but that info is not there, typically on other platforms that info is there). So I had only one option, create a new account, this time attempt to create and activated account from the same machine. I also was thinking, maybe some profanity detection software is confusing “Hatter” with “Hater” and banned my account immediately, but I though there’s no way “Fedora” and “red Hat” devs are not familiar with who a Hatter is. But before attempting to try and create new account, I decided to go to one more place, accounts.fedoraproject.org and try to login there, and to my surprise, it successfully logged in, but said my password is expired and I had to create a new one. So I did, old pass, new pass, confirm new pass, done. Reviewed my profile and signed out. Whew.

Another minor user experience issue. When I tried logging in again on ask.fedoraproject it asked me to create and review profile, again. I decided to remove my full name and confirm.

So in conclusion. That message should be investigated. If you click sign up, it should redirect you to a sign up page. Under login box, account creation box, or after error message, contact email should be included, for login\profile issues only, because users might feel like they hit the dead end.

Thanks for this feedback. I’m moving it to the Site Feedback category.

Hi Same here,

I created an account yesterday and seems that today my PW already needs to be changed ^^’

Thanks to post above i did not pull my hair out ^^.

Had exactly the same problem. Only using search engine and finding this post has let me create an account and login. Wonder how many potential new users you’ve turned off? Half? 3/4? More?

This definitely isn’t happening to a large percent of registrations, but it seems like we have enough that it’s worth making our infrastructure team aware of it and we can see what we can figure out. I do appreciate your reports.

Can someone confirm something: when you got the " Authentication token is no longer valid; new one required" messages, was that from this site or from the single-sign-on site https://id.fedoraproject.org/?

SSO site for me.

I’ve created a Fedora Infrastructure issue to track this: Issue #10946: User reports of "Authentication token is no longer valid; new one required" errors from SSO when logging in - fedora-infrastructure - Pagure.io

1 Like

FYI: the infra team has replicated some problems and are working on this.


Hey, i just created my second account here on fedoraproject. org, and there are a lot of issues:

  1. I needed 4 login tries to login
  2. the single sign on does not work, i was signed in on account.fedoraproject. org but not on ask. fedoraproject. org
  3. My first account is completely unable to login, message: "Authentication token is no longer valid, new one required
  4. Account creation finish (password create step) is bugged as well, i had a message that there was an error and that i will need to reset the password on first login.

A similar thing was reported in August 2022: https://discussion.fedoraproject.org/t/fedora-account-creation-issues-report/73400

I am not new to fedora but such things are a complete disaster for newcomers that have problems.

WTF i cannot post because new users can only have 2 links in a post, please reconsider such dumb rules.

The infrastructure team is aware of the intermittent authentication issues and are looking into it. It isn’t consistent, so it is hard to diagnose. Sorry you ran into that.

As for the link restrictions for new users — again, sorry that it’s frustrating, but spam is a real problem, and since we run on volunteer moderators, we really need the protection.


Hey folks! I fixed an issue in Noggin (the signup & profiles app) that could have caused new users to have an expired password. It’s released and deployed as of now. Hopefully this won’t happen again, thanks a lot for the feedback.


Thank you, Aurélien!