Fedora 40 startup error - Job dev-disk-by\xxxx unlimited

During a minor F40 update about 2 weeks ago, I got this message on my mac mini M2

After more than 16 hours of waiting, I decided to force the shutdown.

But now I get this message every time I start up

I’m a beginner, I can’t get anywhere…
When I press any key to stop boot, nothing works.
I’m totally blocked at this stage

I really need your help because I really don’t know what to do now (just to access the “grub?” menu or a console…)

1 Like

Another think, when i press “esc” when i see “job dev-disk”, these 3 points appear… but nothing else happens

[SOLVED] Boot hang - Job dev-disk-by\x2uuid... [no limit] - #3 by computersavvy

1 Like

Thx man

But i have a problem, i cannot write something anywhere :slight_smile:

what’s the step I don’t understand :smiley:

First try booting from an older kernel using the grub menu. (normally accessible by holding down the shift key during the early stage of booting, just after the bios splash screen.)

If that is not possible you may need to boot to the live media then do the fix from there.

1 Like

Holding shift doesnt work (i have try loooot of key, nothing work…)
Maybe i need to buy an official apple keyboard ?

Ok so i need to create an usb bootable of Fedora 40 ? Is that ?
Is there a specific version to take, or specific instructions to execute? I’ve already tried to connect a bootable key with F40, but nothing happened.

I can access this menu (with the power button) (macos work)

The USB key is detected in option

How can I boot to the live, I created the usb key with rufus and the aarch64 image (raw.xz) of F40 workstation, is this what I have to do?

Then how do I boot on the USB key ?

You have never stated which mac you are using. Looking back through all the posts it appears you are using f40 on a 2023 Mac Mini so that may be apple silicon. I don’t know as I do not use apple hardware in any form.

The aarch64 image is for use on arm processors. Is yours arm? intel x86_64, or apple?

Providing details help us answer with more relevant information.

Maybe someone who has experience can assist.

1 Like

Added apple, f40

this might help

I have a mac mini 2023 with Apple M2 processor

I’m on F40, I’ve upgraded several times since I was on F39 before.

And one day during an update I got the error " Job dev-disk-byx2uuid… [no limit]", this error is known and can be solved as the vgaetera link indicates.

But I can’t find how to run “cat /proc/cmdline”.

Another question, I created a bootable USB key with F40 KDE (and not workstation because I’m on KDE and not gnome… first mistake :D)

Does the USB stick have to be formatted in FAT32 by rufus?

Open a terminal window and run that command there.

Added kde

THIS is the problem, i cannot open any terminal window

How to do this ?

I’m also currently trying to boot on the USB key, but I can’t manage it at the moment.

Do you have the activities menu?

The icon in the upper left corner, or the “Super + A” key combo opens that up on most systems.

I didn’t quite understand

I can’t start fedora. THE PROBLEM ===> I can’t find a way to launch the terminal to execute the fix needed to start it up. <=====

The only screens I can access are the ones pictured in the post above.

Super + A doesnt work anywhere actually

Summary of where I am

1/: I’ve found out where the startup error comes from and how to fix it
2/: I can’t find out how to launch a terminal to fix the problem

3/: I’ve found how to launch the terminal via bootable USB key, and then fix the problem, but I can’t get my bootable USB key to detect, it seems impossible on Asahi + apple silicone mac (cf: Reddit - Dive into anything )

Now I understand a bit more.
You are totally unable to boot.

How did you install fedora initially if unable to boot from USB?
It seems you must fall back to that method.