Fedora 40 not working with Nvidia GPU

I started this process right now by uninstalling all nvidia stuff.

$ dnf list installed '*nvidia*' | tail -n 15 | awk '{print $1}' | xargs sudo dnf remove -y

Such that when I tried searching for installed instances, nothing showed up. Fresh slate.

I started by trying this , as my GPU is after 2014 (what it considers “non legacy”).
This section lists commands I have already tried running. This one in particular breaks as I described in my last response.

sudo dnf install akmod-nvidia

As far as CUDA installation attempt, I received this error

$ sudo dnf install xorg-x11-drv-nvidia-cuda
Error: Unable to find a match: xorg-x11-drv-nvidia-cuda

When I try searching for cuda:

$ dnf search 'nvidia' | grep 'cuda'

nvidia-driver-cuda.x86_64 : CUDA integration for nvidia-driver
nvidia-driver-cuda-libs.i686 : Libraries for nvidia-driver-cuda
nvidia-driver-cuda-libs.x86_64 : Libraries for nvidia-driver-cuda
xorg-x11-drv-nvidia-390xx-cuda-libs.i686 : CUDA libraries for xorg-x11-drv-nvidia-390xx
xorg-x11-drv-nvidia-390xx-cuda-libs.x86_64 : CUDA libraries for xorg-x11-drv-nvidia-390xx
xorg-x11-drv-nvidia-470xx-cuda-libs.i686 : CUDA libraries for xorg-x11-drv-nvidia-470xx
xorg-x11-drv-nvidia-470xx-cuda-libs.x86_64 : CUDA libraries for xorg-x11-drv-nvidia-470xx
xorg-x11-drv-nvidia-cuda-libs.i686 : CUDA libraries for xorg-x11-drv-nvidia
xorg-x11-drv-nvidia-cuda-libs.x86_64 : CUDA libraries for xorg-x11-drv-nvidia
cuda-nsight-compute-12-4.x86_64 : NVIDIA Nsight Compute
cuda-nsight-systems-12-4.x86_64 : NVIDIA Nsight Systems
cuda-nvtx-12-4.x86_64 : CUDA NVIDIA Tools Extension
libnvimgcodec-cuda-11.x86_64 : NVIDIA nvImageCodec library for CUDA 0.
libnvimgcodec-cuda-12.x86_64 : NVIDIA nvImageCodec library for CUDA 0.

My GPU isn’t part of either of the explicit series listed, so I just installed nvidia-driver-cuda.x86_64. That installation actually ran, so I’m going to try rebooting and seeing what happens.

1 Like