Fedora 40 and Gnome 46 not working with Tray Icons Reloaded extensions

I use this extensions
https://extensions.gnome.org/extension/2890/tray-icons-reloaded/
with
https://extensions.gnome.org/extension/1160/dash-to-panel/

After upgrade to Fedora 40 and Gnome 46 it shows just 1 of 4 icons. For example Caffeine is not in the panel/dock.

What is the problem? On other distros with Gnome 46 it’s working, on Fedora 39 too.

Added f40 and removed f39

Tray Icons reloaded only works on X11, Are you in an Xsession ? You can try Gnome on XOrg from the login screen or I believe Gnome Classic.

  • It’s only works with Xorg and XWayland.
  • Appindicator and similar extensions are not compatible, disable it (some distributions ship it by default ex. Ubuntu based).
  • If you have some trouble with compatibility you can try snixembed it also adds visual native menus.
  • Master always targeting current GNOME stable release.

I stopped using it a long time ago because of this. . .

Consider filing a Bug on the project’s GitHub.

1 Like

So it’s not working anymore? :frowning:
Thats a big problem for me.

It hasn’t worked properly on Fedora since F34? I stopped using it then.

Some users had mixed results with it. Ask in their Issue tracker to see what can be done. This really is not a Fedora issue since it is a Gnome extension and is developed by a third party as well.

1 Like

From what I understand (which isn’t a lot) tray icons is a big mess at the moment. I believe there are various considerations from X11/Xwayland/Wayland, to Gnome and their goals, and how applications themselves have implemented it.

@ooooo have you tried AppIndicator and KStatusNotifierItem Support ?
Extension: AppIndicator and KStatusNotifierItem Support - GNOME Shell Extensions
Github: GitHub - ubuntu/gnome-shell-extension-appindicator: Adds KStatusNotifierItem support to the Shell

Once installed, logout of Gnome and back in again. It didn’t work for me until that action took place.

2 Likes

Its just a problem on Fedora 40. In 39 its working perfectly fine. On Arch with Gnome 46 it’s also working.