Fedora 39 update issue: Error running transaction nvidia libs

  1. hey guys, trying to upgrade from fedora 38 to 39 and this error pops up, any idea how to solve it? Error running transaction: file /usr/lib64/libnvidia-egl-gbm.so.1.1.0 conflicts between attempted installs of egl-gbm-1.1.0-5.fc39.x86_64 and nvidia-driver-libs-3:535.86.10-1.fc37.x86_64

I am using the software desktop application to download fedora 39

I think you are using the NVIDIA driver from nvidia.com?
I’m basing this assumption on the fact that I do not have any nvidia-driver-libs package installed and also that the package is for fedora 37 and that odd for a fedora 38 system.

If so I recommend that you change to use the nvidia driver code that is packaged by rpmfusion that lots of us use and they work well with Fedora.

See Howto/NVIDIA - RPM Fusion for the details.

You will need to uninstall all the nvidia.com code first and remove the nvidia repo from /etc/yum.repos.d.

Hey @barryascott , I have successfully removed the old nvidia fedora 37 drivers repo and downloaded fedora 39. Now I am having issues in downloading drivers for fedora 39

I am getting the following error

RPM Fusion for Fedora 39 - Nonfree - Updates                                   13 kB/s |  14 kB     00:01    
Error: 
 Problem: conflicting requests
  - package akmod-nvidia-3:535.129.03-1.fc39.x86_64 from rpmfusion-nonfree requires nvidia-kmod-common >= 3:535.129.03, but none of the providers can be installed
  - package akmod-nvidia-3:545.29.06-2.fc39.x86_64 from rpmfusion-nonfree-updates requires nvidia-kmod-common >= 3:545.29.06, but none of the providers can be installed
  - package xorg-x11-drv-nvidia-3:535.129.03-2.fc39.x86_64 from rpmfusion-nonfree is filtered out by modular filtering
  - package xorg-x11-drv-nvidia-3:545.29.06-2.fc39.x86_64 from rpmfusion-nonfree-updates is filtered out by modular filtering
(try to add '--skip-broken' to skip uninstallable packages)

Can you help me with this ?
I only ran the command sudo dnf install akmod-nvidia

NVM, I fixed it by doing this sudo dnf module disable nvidia-driver

Glad you figured that out.
The modular package conflict is often the case when a user has installed the driver directly from nvidia.