Unable to Install Proprietary NVIDIA drivers on Fedora 39

  1. I keep on getting errors from Fedora about missing nvidia kernel modules on my Fedora 39 installation. I’m getting this:
07:12 ~ modinfo -F version nvidia
modinfo: ERROR: Module nvidia not found.
✘ 07:12 ~ 

And also have disabled secure-boot from the get-go. Can someone tell me what im doing wrong?

I also can’t seem to find it (NVIDIA 535) on the software app at all.

Make sure third-party repos are enabled

First type
sudo dnf install akmod-nvidia

Wait about 5 minutes or so

Then check
modinfo -F version nvidia

When it shows version

sudo reboot

All done when no secure boot enabled

This is my output:

08:06 ~ sudo dnf install akmod-nvidia
[sudo] password for tegaidogun: 
download.vscodium.com                           5.0 kB/s | 866  B     00:00    
Last metadata expiration check: 0:00:01 ago on Sat 14 Oct 2023 07:54:31 AM EDT.
Error: 
 Problem: conflicting requests
  - package akmod-nvidia-3:535.113.01-1.fc39.x86_64 from rpmfusion-nonfree requires nvidia-kmod-common >= 3:535.113.01, but none of the providers can be installed
  - package akmod-nvidia-3:535.113.01-1.fc39.x86_64 from rpmfusion-nonfree-nvidia-driver requires nvidia-kmod-common >= 3:535.113.01, but none of the providers can be installed
  - package xorg-x11-drv-nvidia-3:535.113.01-1.fc39.x86_64 from rpmfusion-nonfree is filtered out by modular filtering
  - package xorg-x11-drv-nvidia-3:535.113.01-1.fc39.x86_64 from rpmfusion-nonfree-nvidia-driver is filtered out by modular filtering
(try to add '--skip-broken' to skip uninstallable packages)
✘ 08:57 ~

Okay, don’t worry I fixed it using this link:

https://rpmfusion.org/Howto/CUDA

Usually when this modular filtering error message is shown it is because the user has installed cuda from a cuda-fedoraXX repo and thus a modular driver is interfering.

The details can be found with dnf module list and dnf repolist the last of which shows the enabled repos. If a repo whose name begins with cuda is shown that repo should be disabled.

if the error continues then the command sudo dnf module disable nvidia-driver should fix it. (the module name may have been shown with the dnf module list command above)