Fedora 38 rtx 2060 driver problem

Hi, I apologize in advance, English is not my native language.

The problem is this, a few days ago I installed Fedora 38 for the first time, previously I used Ubuntu. After installing the drivers on my rtx2060 video card, my screen flashes randomly and behaves incorrectly, also in the settings in the “display” tab, I have an unknown second monitor, but this was fixed with:

Every time I start the system, I receive a notification from abrt with the following content:

An error has occurred in the kernel, your kernel contains non-free components (flags:POE). Explanation:
P - The proprietary module has been loaded.
The O-Out-of-tree module has been loaded.
The E - Unsigned module is loaded.
Developers cannot diagnose reports in such kernels.Damaged modules: nvidia_drv,nvidia_modeset,nvidia_wdm,nvidia.

installed the driver using the command:

sudo dnf install nvidia-driver

Then I waited about 15 minutes before rebooting

modinfo -F version nvidia

$ nvidia-smi
Mon May  1 08:36:13 2023       
| NVIDIA-SMI 530.41.03              Driver Version: 530.41.03    CUDA Version: 12.1     |
| GPU  Name                  Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf            Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                                         |                      |               MIG M. |
|   0  NVIDIA GeForce RTX 2060         Off| 00000000:01:00.0  On |                  N/A |
| 38%   32C    P8                9W / 160W|    184MiB /  6144MiB |      1%      Default |
|                                         |                      |                  N/A |
| Processes:                                                                            |
|  GPU   GI   CI        PID   Type   Process name                            GPU Memory |
|        ID   ID                                                             Usage      |
|    0   N/A  N/A      2070      G   /usr/bin/gnome-shell                        128MiB |
|    0   N/A  N/A      2762      G   /usr/libexec/xdg-desktop-portal-gnome         5MiB |
|    0   N/A  N/A      3197      G   /usr/bin/Xwayland                             2MiB |
|    0   N/A  N/A      3532      G   /usr/bin/gnome-control-center                17MiB |
|    0   N/A  N/A      4427      G   telegram-desktop                              2MiB |

Switching to xorg solved the problem, but I’m not sure for sure, sometimes errors still appear, but at the same time nvidia x server seems to have full settings

Apparently you installed the driver from the fedora-cuda repo.
That is not the recommended source (which is rpmfusion) and the only assist I can provide is to guide you through uninstalling that then installing from rpmfusion. The drivers from the rpmfusion repo have seemed to work properly for all.

If you decide that is your choice let us know.

1 Like

Hi, my driver is installed from the rpmfusion repository. I don’t have a fedora-core repo

Yes, don’t worry about it.

The xorg-x11-drv-nvidia-cuda package from RPM Fusion provides nvidia-driver.

On Wayland, the NVIDIA Settings will not have much options compared to X11. That is a limitation of Nvidia’s program. Wayland Support · Issue #69 · NVIDIA/nvidia-settings · GitHub

But nevertheless, the problem with the flashing screen in weyland persists and also notifications about damaged nvidia modules

I stand corrected. I was not aware that nvidia-driver was included in the xorg-x11-drv-nvidia-cuda package

Please post the output of dnf list installed '*nvidia*'
If possible provide the notifications about the damaged modules received as well.

dnf list installed '*nvidia*'
Установленные пакеты
akmod-nvidia.x86_64                                              3:530.41.03-1.fc38                         @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-6.2.13-300.fc38.x86_64.x86_64                        3:530.41.03-1.fc38                         @@commandline                   
nvidia-gpu-firmware.noarch                                       20230404-149.fc38                          @updates                        
nvidia-persistenced.x86_64                                       3:530.41.03-1.fc38                         @rpmfusion-nonfree-nvidia-driver
nvidia-settings.x86_64                                           3:530.41.03-1.fc38                         @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64                                       3:530.41.03-1.fc38                         @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda.x86_64                                  3:530.41.03-1.fc38                         @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64                             3:530.41.03-1.fc38                         @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64                               3:530.41.03-1.fc38                         @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64                                  3:530.41.03-1.fc38                         @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-power.x86_64                                 3:530.41.03-1.fc38                         @rpmfusion-nonfree-nvidia-driver

The problem may be the formation of the command line for booting.
Try rebooting and at the grub menu (May need to hold the shift key while booting to see the menu) press the e key for editing.
Insert the following into the line that begins with ‘linux’
nvidia-drm.modeset=1 initcall_blacklist=simpledrm_platform_driver_init
then use ctrl + X to continue booting and see if that solves the crash notifications.

If it does then that can be made permanent with editing /etc/default/grub and adding the same entries into the line beginning with ‘GRUB_CMDLINE_LINUX’ then running sudo grub2-mkconfig -o /boot/grub2/grub.cfg. The next boot will include those options in the kernel command line.

Unfortunately, this did not bring any results. If any additional information is needed I am ready to provide it

I also noticed that when watching videos, horizontal breaks are observed, for example, as in games when vertical synchronization is disabled.

Hey i have the same graphics card as you on fedora 38…tried everything…and still flickers…i think that it has something with G-sync if your monitor supports it…and 530 drivers are not suporting it…wait for 535 nvidia drivers when they add it into a repo and try those drivers…i am waiting for them too, nothing else can solve the problem…535 drivers came out 3 days ago…and i saw in the fix list mentioning wayland fix and g-sync fix with ton of other fixes…wait and see…