Multiple problems in Fedora 38

Hi, I installed Fedora 38 yesterday, on a Lenovo Legion Y-450 laptop. I installed several applications, enabled additional repositories and downloaded proprietary NVIDIA drivers from the software store. I have a great deal of problems with Fedora. The boot time is very long, I have to type the password to decrypt the disk on every boot (I don’t know if it’s a bug) When playing native Linux games, I have 1 to 20 fps (after a while the system shuts down due to x X11 error) and every now and then my system has some critical X11 related error, even when checking the forum my system had an error. I thought it was a Wayland related error, so I fired up GNOME on Xorg session, no change. Is this some general problem with NVIDIA GPU’s, or is it just my laptop? (Ignore the system error tab, it was an one time GNOME shell crash)

EDIT: The boot times somehow got shorter, the encryption stopped bothering me, but the driver issues still persist

I typed nvidia-settings in the command line, the output says that the NVIDIA drivers aren’t loaded. Maybe the open source driver is used, even if I have the proprietary one?

This is the recommended way to install the NVIDIA driver:

Nothing changed

Make sure that you have removed all other irrelevant NVIDIA drivers, correctly determined your card model, installed the driver exactly for your card model, and the kernel actually loads the installed driver for your card.

Just to be sure, my card is fairly new (GTX 1650), so I only need to type the 3 commands in the Current GeForce/Quadro/Tesla section, right? Unless I need to do more than that, I think I have done all I can. I have reinstalled the drivers using dnf, but there is still no visible effect. Should I install the drivers using the harder method (Official Advanced Driver Search | NVIDIA).

Check the output:

dnf list \*nvidia\* --installed
dnf module list --installed
switcherooctl list
lspci -n -n -k

Sorry, but what should I put in module name?

It should be the kernel driver in use listed be the previous command.

This helps you identify the package that owns the module:

rpm -q -f $(modinfo -n MODULE_NAME)

As far as I remember, it should match the package built with akmods from RPM Fusion.

I will send back the output as soon as I get back home

That would not be advisable since it is different.
What are the results of the commands previously suggested, especially the dnf list installed \*nvidia\*.?
Also, what is the output of mokutil --sb-state?
If secure boot is enabled the system will not be able to load and use the nvidia drivers until one either disables secure boot or has signed the nvidia modules.

More info:

I also found the system is more “stable” when not having NVIDIA drivers installed

Also, a game that used to launch and have low fps, now doesn’t even launch

It worked for me, issue closed :grinning:

1 Like

It is a feature for me. By default you need to type at least your root partition password if encrypted. You can auto unlock other partitions (by storing their keys on your root partition).

Or you could store your key in the TPM for auto unlocking.