Fedora 38: migrating from NVidia to AMD

Hello gentlemen!

How should I change the videocard properly? Now I’m using RTX 2080 FE with the actual .run driver from the NVidia official website. My system is Fedora 38 Workstation.

I’m going to change the adapter to Sapphire RX550 as temporal solution. The final hardware decision will be RX7700/RX7800.

Should I use multi-user.target mode? Should I uninstall the NVidia .run driver?

1 Like

I suggest you first install the new hardware.
Then uninstall the nvdia RPMs.
There is nothing special to install for AMD as it will already be installed.

Barry, your advice works perfectly!

But I can’t launch the Guake shell by the F12 button.

I had the same problem with the NVidia videocard if I used the default nouveau driver . The problem left after the installing a proprietary NVidia driver.

Could you give me a recommendation about Radeon drivers?

I do not know what Guake is; also I’m on NVidia drivers so cannot test for you.

Usually I start a program that fails from a terminal to see if it prints out any error messages.
You could try that and see if the messages hint at what stopping it launch.

I also do not know what Guake is, but the F12 button during boot is probably getting the bios boot menu and thus no shell is available at that point. A user shell is only available when a kernel has already booted.

The drivers for the amd/radeon GPUs are part of the distro and should automatically load when the system sees that hardware during boot. Use the provided drivers that are already available.

There is usually no need to make the transition as you indicate, simply install the final card (unless you do not have it on hand yet.)

Guake is the GNOME drop-down terminal emulator: Guake github. So, when I push F12 button the Guake appears in the top half of my screen. After the second push it disappears.

Thanks for clarifying.
This is not happening during boot, but rather after having already logged in and when opening a 3rd party terminal app.

Thus the problem appears to be the app itself and not necessarily directly related to fedora. It may or may not be impacted by the driver for the GPU.

=Jeff=, obviously you are right , but I must say that the Guake toggle issue starts after some drivers trouble. That’s quite suspicious…
I’ve binded a shortcut in the Fedora Settings menu, so it toggles by the F12 key successfully.

Today :smile: I’m searching how to prevent the Guake size changing after the toggle on command. You know, it occupies the top half of the screen by defaults. Now it centered in the top half instead of Guake preferences. Then I switch to another application and return to Guake terminal. And Guake occupies the full top half of the screen.

Have you tried asking the Guake maintainers for help?

=Barry=, of course. And I’ve reduced the terminal window width in the Guake preferences. I use 50% of available width. Now it works normally. I’m positive that’s the bug in the preferences GUI.

FYI @ilya-shmadchenko if you can direct replies to a person using @name

Just an FYI.
If the user clicks on the reply link at the lower right of the post being responded to it gives the name of the one the response is for (as you see with this post).
If they click on the blue reply button at the lower center it is not directed to the specific user but instead is for the thread as a whole.

I agree that adding the @username is a bit more specific in directing the comments.