Fedora 38 Installation on an external USB drive

I used the Fedora Media Writer and successfully downloaded the Fedora 38 ISO and installed it on a flash USB 32 GB drive. This did indeed boot and got the screen prompting to proceed with the installation.

The USB flash drive does not show up on the target drive for the installation. The same result I had using a 2 TB USB drive.

I then booted up using the 32 GB flash drive with the 2TB drive (now cleared and fully unallocated). Only then the external drive appears. i.e. the external USB drives only show up if they a blank/unallocated.

I then proceeded with the auto installation that completed successfully, however it does boot. I tried the other two installation options for the disk configuration and got the same result. The installation does not boot.

I attempted multiple installation variations and failed to get a bootable external drive complete installation that works.

Welcome to the Fedoraproject @ahamoodi

While using external devices you have to watch that you write the grub2 to the external disk. Make sure that your external device is on the boot list before the internal one (checking in bios). Unfortunately in bios fedora boot options are marked as “fedora”. If you have more it is quite tricky to make the right one boot.

Important is that you also use a own EFI partition on the external disk. If you use Legacy boot option you also have to activate it in bios.

1 Like

Thank you for your kind response and support.

I again attempted a “custom” the default, a Workstation installation disk layout as in the documentation:
Role Filesystem Mount Point
EFI System Partition FAT 32 /boot/efi
Boot Partition ext4 /boot
Root Subvolume Btrfs /
Home Subvolume Btrfs /home

The installation completed successfully. However, it does not boot.

My bios is configured to boot first from the USB and last for the internal HD. It boots fine using the flash drive or the same usb HD when I install the Fedora ISO using the Fedora Media Writer.

I cannot figure out how to get the Fedora 38 installation to boot from the external USB drive.

Please check with gparted (intall: sudo dnf install gparted) if the efi has the boot and esp flag.

Klick on the EFI partition > Partition > manage flags and click on boot and on esp.

1 Like

Thanks again.

I installed gparted and repeated my attempts and confirmed that the boot and esp flags are checked for the efi boot partition, and still failed to boot Fedora 38 installation.

see attached screenshots

20230427_135245 (Small)

Your mount-points are different as mine:

Screenshot from 2023-04-27 08-42-18

Thanks again.

It is my fault… I figured it out… It was a simple case of not pressing F12 when booting to select the boot option.

What through me off was the direct booting from the USB flash drive of Fedora 38 ISO prepared using the Fedora Media Writer…

Thank you and I apologize for your time, much appreciated.