Cannot install Fedora 38: bootable flash drive not detected

Hello, I am trying to install Fedora on my computer but the flash drive is not automatically detected as an option for booting.
I have disabled the secured booting option and I have mounted the official “Fedora-Workstation-Live-x86_64-38-1.6” iso using Rufus. The partition scheme is HBR and the format of the file is FAT32.
However, I can manually add a booting option in the BIOS menu (cf. image below) but I am asked to tell a precise path and I do not know what file to choose…

Any help is appreciated !

  • Can you try to boot USB with another computer to see if another computer can detect install media?
  • Can you make install media using different app, not RUFUS, e.g., Fedora Media Writer ?

Selecting to boot from a usb device usually means one must use the bios boot menu, (F8, F10, F11, or F12 for most systems) or with the usb device attached boot into the bios configuration menu (F1, F2, or Del for most systems) and add that device as the first boot option. Almost all modern bios is designed to not boot from USB or CD unless one specifically selects to do so.

Additionally, without knowing the bios on your system one cannot test what you describe. I have never seen a “File Explorer” within bios on any system I have used.

Probably grubx64.efi.

I recall seeing this so that a new BIOS firmware image can be installed from the USB stick.

Thanks for your help but:

  • I have tried the flash drive with another computer which is also a Dell, in fact it is almost the same computer, but I get exactly the same result.
  • And I have just tried Fedora Media Writer, but I do not know why it keeps showing me this error message:

Ok problem solved, thanks everybody ! When mounting the flash drive I had to choose GPT as a partition scheme…