Fedora 38 installation fails, "Failed to resolve the Live OS image."

I downloaded the F38 KDE spin ISO and verified the GPG signature and checksum. I then used the Fedora Media Writer on my existing F35 system to write that ISO to a 16 GB USB drive. I booted to the USB drive and ran the media check from the GRUB menu, which passed without errors. Then I ran Anaconda by clicking the desktop icon in the live system.

The first time I tried to run the installer, I got an error and the option to file a bug report, which I did: 2210933 – pyanaconda.modules.common.errors.general.AnacondaError: could not find parent for subvol. Here is the anaconda.log file: http://ix.io/4x4o

I ended up having to kill the installer process from Konsole with kill -9 because the application was completely frozen and was not responding to any of my input. Running a 2nd (and 3rd and 4th) time, the error in the screenshot popped up. I even tried re-writing the USB drive a 2nd time because I thought I had maybe messed something up.

The following error occurred while setting up the payload. This is a fatal error and installation will be aborted.

Failed to resolve the Live OS image.

The fact that I got an error about subvolumes suggests that somehow the installer is crashing when trying to probe the current system for storage drives.

Some notes about my system:

  • I currently have F35 installed on a BTRFS filesystem with several snapshots
  • I have a Windows installation on my other internal SSD, a physically distinct drive from the one with Fedora on it
  • I have an external HDD connected, NTFS formatted
  • I have rEFInd installed and used it to boot into the live system

I can’t think of anything else unusual about it.