Fedora 37 x86 Qemu Virt manager. Live ISO does not get to desktop (just logon screen)

The install makes it to the logon screen which has is user called “Live System User”.

If I attempt to logon to that account it just sits there doing nothing. Eventually I reboot and…

On reboot I am greeted by the bios error message “No bootable device”.

Host is Ubuntu 22.04 using qemu and Virtual Machine Manager.

Any ideas?

This sounds like it is booting to the live install media and you are not proceeding. That should be a gui desktop interface as if you had actually already logged in. From that location you need to select the icon to install to hard drive so it actually does the install.

Thanks. But as I mentioned the live CD boots straight to the logon screen and if I attempt to logon (presumably to continue the install) nothing happens. It just sits there on the logon screen (but now with user icon disappeared).

If I do not attempt to logon it just sits there at the logon screen.

So as far as I can see there is no automatic login!!! From the live ISO.

In addition after about 10 minutes of sitting at the logon screen it just completely hangs/freezes.

I have not yet tried the 37 Beta ISO so have never seen that. Will test on my system.
With every released version I have never seen that login screen when booting the live ISO.

I just downloaded the latest Beta iso Fedora-Workstation-Live-x86_64-37_Beta-1.5.iso and created a new VM on my system (QEMU & VMM) then installed it. It proceeded as expected through the boot to live image and when selected it did the normal install to my VM. The newly installed VM then booted properly.

You are running an Ubuntu host and I am running a Fedora host, both using QEMU/KVM and VMM so I would not expect any significant differences in the install. I certainly would not expect to see a login screen prior to doing the install as you show in the image above which leads me to believe you have not followed the normal path to do the install or that something occurred during the install to cause failure to complete.

Once the installation completes there is a finish installation button that appears at the lower right of the screen. Clicking that then using the icon at the upper right to select a restart actually finishes the install and does the first reboot of the new system.

The very first boot after a new install of fedora does not come to a login screen as you show but rather to a setup where the user creates his users login and does some minimal configs before it actually boots into the desktop. Only the second and subsequent boots actually reach that login screen.

My newly installed F37 Beta system below.

If you haven’t tried the version I am using then thanks for taking the time but I was hoping someone else could try the same version and say the problem appears to be just with me or they can confirm the issue.

I just tried the same iso with VirtualBox and the installation proceeds perfectly as described. So the issue is only with qemu.

You saw that you can change the type of Video while using a vm in Virt Manager ?

(Show virtual hardware details)

This helped me to get the wide screen resolution working (2560x1080~60Hz), when I changed from GLX or VGA to Virtio. You might have to check to see what the system took when you created the VM.

Thanks. Video seems to be displaying OK but I will try changing it to see if it gets around this installation issue.

That fixed it. Changing the Video to Virtio fixed the installation issue. Maybe the standard VGA res is too low for installer!!!

1 Like