Fedora-Workstation-Live-x86_64-37-1.7.iso does not work with Virtualbox 7.0.6 (on windows 11)

After installation on the VM it’s not really installed. It’s just the live Version. Ubuntu works just fine, but Fedora 37 Workstation does not. ChatGPT can’t help me either so I deceided to ask here. Can anyone replicate my issue? Is it me?

1 Like

Welcome to the Fedoraproject @qqeettuu

Can you please tell us what exactly you made?

Just for short, you have to create a new Virtualbox, selecting fedora Linux and as a boot CD you can use the iso you downloaded.
Then start from Iso. Now you have to install it to your created virtualbox.

Did you do something like this?

1 Like

Did you remove the live image on reboot, after installation? did you set priority to boot the vm from HDD?

If not it keeps booting the live image despite having installed fedora.


Yes, that is exactly what I did. It’s not my first time either. It worked without issues using HyperV on Windows 11 Pro and Ubuntu works just fine on VirtualBox, too.

I made a photo were you can see it says it has been installed.
When I eject the install medium it just stops working. It also never asked to create a user. So I’m at a los here.

User creation is after reboot, within the installed system, not during install.

At that screen you click the button on the lower right, then reboot to launch the installed VM. (do that before removing the install media). Once the VM starts it will do the initial setup where a user is created.

The thing is that is exactly what is not happening. It just goes back to the menu to start the installation process.

I haven’t done this for a while, but it’s possible that there is a race situation — I mean, not a race condition bug, but one where you will need to disconnect the boot media from virtualbox after the installation is complete, but before it boots.

That actually worked! Thank you very much!

1 Like