Fedora 37 unable to detect external monitor in my Thinkpad X1 Carbon Gen 10

I have connected my external monitor via a type c port and have tried connecting via HDMI too, fedora display settings is unable to detect an external monitor. But when i open BIOS and switch the boot from external display then my external display becomes the only the display to be visible.

This is a device with Intel Alder Lake-UP3 GT2 [Iris Xe Graphics]. I can confirm that the display works with other laptops and also the confirm that the ports in this laptops are functioning as the BIOS can detect my external display.

Here is the output of : inxi -Fxz

  Kernel: 6.5.7-100.fc37.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.38-27.fc37 Console: pty pts/0 Distro: Fedora release 37 (Thirty Seven)
  Type: Laptop System: LENOVO product: 21CBCTO1WW v: ThinkPad X1 Carbon Gen 10
    serial: <filter>
  Mobo: LENOVO model: 21CBCTO1WW serial: <filter> UEFI: LENOVO
    v: N3AET71W (1.36 ) date: 01/31/2023
  ID-1: BAT0 charge: 43.2 Wh (74.7%) condition: 57.8/57.0 Wh (101.4%)
    volts: 17.3 min: 15.4 model: Sunwoda 5B10W13975 status: charging
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
    charge: 50% (should be ignored) status: discharging
  Info: 10-core (2-mt/8-st) model: 12th Gen Intel Core i5-1235U bits: 64
    type: MST AMCP arch: Alder Lake rev: 4 cache: L1: 928 KiB L2: 6.5 MiB
    L3: 12 MiB
  Speed (MHz): avg: 796 high: 1110 min/max: 400/4400:3300 cores: 1: 400
    2: 970 3: 1110 4: 907 5: 902 6: 648 7: 400 8: 1010 9: 400 10: 910 11: 894
    12: 1006 bogomips: 59904
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel Alder Lake-UP3 GT2 [Iris Xe Graphics] vendor: Lenovo
    driver: N/A arch: Gen-12.2 bus-ID: 00:02.0
  Device-2: Syntek Integrated Camera driver: uvcvideo type: USB
    bus-ID: 3-8:4
  Display: server: X.Org v: 22.1.9 with: Xwayland v: 22.1.9 driver:
    dri: swrast gpu: N/A resolution: 1920x1080~60Hz
  API: OpenGL v: 4.5 vendor: mesa v: 23.0.3 glx-v: 1.4 direct-render: yes
    renderer: llvmpipe (LLVM 15.0.7 256 bits)
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Lenovo
    driver: sof-audio-pci-intel-tgl bus-ID: 00:1f.3
  API: ALSA v: k6.5.7-100.fc37.x86_64 status: kernel-api
  Server-1: PipeWire v: 0.3.80 status: n/a (root, process)
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3
  IF: wlp0s20f3 state: up mac: <filter>
  Device-1: Intel driver: btusb v: 0.8 type: USB bus-ID: 3-10:5
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.3
    lmp-v: 12
  Local Storage: total: 476.94 GiB used: 17.85 GiB (3.7%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVL2512HCJQ-00BL7
    size: 476.94 GiB temp: 36.9 C
  ID-1: / size: 475.34 GiB used: 17.53 GiB (3.7%) fs: btrfs dev: /dev/dm-0
    mapped: luks-a2506bf0-7859-4b07-89de-1576fd60c206
  ID-2: /boot size: 973.4 MiB used: 287.5 MiB (29.5%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 38.8 MiB (6.5%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 475.34 GiB used: 17.53 GiB (3.7%) fs: btrfs
    dev: /dev/dm-0 mapped: luks-a2506bf0-7859-4b07-89de-1576fd60c206
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  Src: /sys System Temperatures: cpu: 50.0 C mobo: N/A
  Fan Speeds (rpm): cpu: 3995 fan-2: 3989
  Power: 12v: N/A 5v: 5 3.3v: N/A vbat: N/A
  Processes: 369 Uptime: 27m Memory: total: 16 GiB note: est.
  available: 15.31 GiB used: 3.27 GiB (21.3%) Init: systemd
  target: graphical (5) Compilers: gcc: 12.3.1 Packages: 7 note: see --rpm
  Shell: fish v: 3.6.1 inxi: 3.3.30

When reporting issues you should provide enough detail to allow others to reproduce the problem. You omitted the details of the external monitor. HDMI and USB-C cables differ widely in quality and support for higher resolutions.

Fewer users are still on F37 (especially those that had issues in F37), so chances of others being in a position to reproduce the issue are small. Many improvements in display support have appeared since Fedora 37, and vendors have updated firmware.

First make sure firmware is updated:

doas fwupdmgr refresh --force
doas fwupdmgr get-updates
doas fwupdmgr update

Then try booting the Fedora 39 pre-release Live Installer to check that the problem has not already been resolved.

X1C9 here, and I’ve connected monitors, graphics tablets and beamers via HDMI directly and via HDMI/VGA through USB-C, usually without any problems.
When you say “fedora display settings”, do you mean the settings of the standard Fedora Workstation desktop environment (which would be Gnome/Wayland)?
Have you updated applied all firmware updates? Lenovo is quite good at pushing them out for the X1C.
Worth trying: Choose Gnome/X11 (the little cog at the login screen) and check whether the monitor is seen now. Speaking of login: Is the external monitor “blank” or grey at the login screen?

Yes it standard Fedora Workstation desktop environment - GNOME.
The firmware is up to date. I have checked that. I just simply can not upgrade to F38 or F39 because of organization’s dependencies.

Is the external monitor “blank” or grey at the login screen?

The monitor detects that it has been connected to a source but it just stays blank and enters sleep to save power because no signal is available.

I have tried it with multiple monitors, my primary monitor is LG 27GL850 and i use the cable from the box.

But my BIOS is able to detect the monitor. And for now I have made the BIOS directly boot on my monitor instead of the Laptop screen. So now the laptop screen is blank.

It may still be useful to check if the problem is solved with a newer Fedora Release by booting a Live Installer. If your “organization’s dependencies” stem from a need for compatibility with some other linux distro you could also use a Live Installer to check if your hardware is supported. Other linux distros may backport bug fixes, so it may be possible to obtain a fix for Fedora 37 if you are willing to rebuild the affected component with a patch borrowed from another distro.

You may want to consider using a VM that supports your “organization’s dependencies” in a current Fedora release.