Fedora 36 Silverblue Printing Problem

Hello everyone.

I don’t have any problems printing PDFs or documents on Fedora 36, but when printing a photo (whether it was taken from a phone or with a camera), it doesn’t print the whole thing, it only takes part of the photo and cuts off other parts. It usually prints the upper left part and does not receive the rest. I looked in system-config-printer but couldn’t figure it out from there. I looked in gThumb’s settings and couldn’t find it there. All settings are set, for example A4 and auto scale etc. Everything is open, but I preview it, but it doesn’t print all of it before printing. Is there anything else I can do?

NOTE: It works fine on Windows. There was no such problem in Fedora before, I guess it just started.

Printer: Kyocera ECOSYS m3540idn

This is very likely an issue with the print driver itself. Does it look OK in the print preview before you print? If so, you could try “printing” to a pdf with the built in print to file driver and then printing the resulting pdf.

1 Like

I believe this is because of driver. I choose as Recommended. I will try also other drivers and will see the changes and return to this topic. It is not looking OK also before print when I choose preview.

1 Like

Does it print a full page on the paper that is only part of the photo? or is it only printing a partial image on part of the page?

With photos problems may occur if your printer has inadequate RAM to receive the entire image before printing starts. If this is the case it will print as soon as the RAM is full, regardless of whether it has received the full amount of the image or not.

If the preview is not showing the print properly then the printed page will not be proper either.

1 Like

I’ve had a few cases where switching between postscript and pcl was what fixed this (more often than not, ps behaves better than pcl, but not always).

1 Like

It prints a full page on the paper that is only part of the photo.

1 Like

I have a similar problem and haven’t really been able to find a solution. I’m trying to print 4"x6" borderless photos. I have a Canon G500 and I’ve tried both the official drivers and driverless printing.

The funny thing is every program I’ve tried has a different behavior: some print only a corner of the photo but borderless, others print the whole photo but the size of a thumb, others print the photo with large borders that didn’t exist in the preview, and so on. I’ve tried dozens of photo viewers as well as GIMP, tweaked every page size/scale and so on setting you can imagine and I can’t get any of them to print a basic, full bleed 4"x6" photo on this printer.

I have honestly given up and just switch to Windows whenever I need to print a photo. There literally any photo print option, including the built-in one in the OS, does fine.

1 Like

IT sounds like the print driver is failing to scale properly in this mode. Are you able to get it to scale properly with “Save to File” to generate a pdf and then print the pdf? I know it’s tedious to do this in two steps, but that might help confirm that it is indeed a vendor printer driver issue and would give you a temporary workaround.

1 Like

I fixed it thanks. It is really easy. It is not related to driver or system-config-printer or something. Just extract the image format by GIMP from jpg, png etc to pdf. Than print and you will see the succession :slight_smile:


Thank you for sharing this solution!