Fedora 36 is very slow and almost unusable

Im using fedora plasma spin and i cant do simple things like opening new tab or open discord because of lagging and so i tried reinstalling the entire setup. it was running quite good 2 days ago but now again it went back to lagging too much

inxi -Fzx-
  Kernel: 5.18.13-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36 Desktop: KDE Plasma v: 5.25.3
    Distro: Fedora release 36 (Thirty Six)
  Type: Desktop System: Gigabyte product: A320M-S2H v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: A320M-S2H-CF v: x.x serial: <superuser required>
    UEFI-[Legacy]: American Megatrends v: F23 date: 08/08/2018
  Info: quad core model: AMD Ryzen 3 2200G with Radeon Vega Graphics bits: 64
    type: MCP arch: Zen rev: 0 cache: L1: 384 KiB L2: 2 MiB L3: 4 MiB
  Speed (MHz): avg: 1552 high: 1591 min/max: 1600/3500 boost: enabled
    cores: 1: 1591 2: 1561 3: 1512 4: 1545 bogomips: 27947
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Mobile Series]
    vendor: Gigabyte driver: amdgpu v: kernel arch: GCN 5 bus-ID: 07:00.0
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 22.1.3
    compositor: kwin_wayland driver: X: loaded: amdgpu
    unloaded: fbdev,modesetting,vesa gpu: amdgpu resolution: 1600x900
  OpenGL: renderer: AMD Radeon Vega 8 Graphics (raven LLVM 14.0.0 DRM 3.46
    v: 4.6 Mesa 22.1.4 direct render: Yes
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
    v: kernel bus-ID: 1-6:2
  Device-2: AMD Family 17h/19h HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus-ID: 07:00.6
  Device-3: Generalplus USB Audio Device type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.18.13-200.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel port: f000 bus-ID: 06:00.0
  IF: enp6s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Local Storage: total: 931.51 GiB used: 183.56 GiB (19.7%)
  ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-22MFCA0
    size: 931.51 GiB
  ID-1: / size: 539.89 GiB used: 183.31 GiB (34.0%) fs: btrfs dev: /dev/sda2
  ID-2: /boot size: 973.4 MiB used: 250.3 MiB (25.7%) fs: ext4
    dev: /dev/sda1
  ID-3: /home size: 539.89 GiB used: 183.31 GiB (34.0%) fs: btrfs
    dev: /dev/sda2
  ID-1: swap-1 type: zram size: 6.72 GiB used: 1.93 GiB (28.7%)
    dev: /dev/zram0
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 38.0 C
  Fan Speeds (RPM): N/A
  Processes: 305 Uptime: 3h 16m Memory: 6.72 GiB used: 3.1 GiB (46.2%)
  Init: systemd target: graphical (5) Compilers: gcc: 12.1.1 Packages: 5
  note: see --pkg Shell: Bash v: 5.1.16 inxi: 3.3.19

also can you explain me this why my home directory is 530gb while i have like a 1tb drive…
size: 931.51 GiB
ID-1: / size: 539.89 GiB used: 183.31 GiB (34.0%) fs: btrfs dev: /dev/sda2
ID-2: /boot size: 973.4 MiB used: 250.3 MiB (25.7%) fs: ext4

Do you run a lot of containers? E.g. for Podman, you might check the output of podman images --all. I think Flatpak has been known to use a lot of space as well.

1 Like

I took the liberty of adding the </> Preformatted text tags to your inxi output since it makes it much easier to read. Please in the future use those tags when posting data you copy&paste from the screen.

What I see as probability for the slow performance is the fact you only have 6G of RAM and more than half is used, thus a lot of swapping seems to be occurring.

Also, to answer about the size of your user space, please post the output of df so we can see the actual available and used space for each partition/filesystem

1 Like

I know a lot of people prefer plasma for its customizing ability and Ubuntu the same, but Fedora offers you a stable system on either Gnome or Pantheon. This of course depending on the RAM Available, Your ability to not install spyware disguised as helper tools, etc. I would say anything from 8 GB, and you won’t even recognize your own computer anymore. Much faster on Pantheon. Use Gnome Packages to install and see for yourself. I myself was attracted to Plasma for that same reason, but I’d rather have a stable system that a lot of strange things working in the background.

Also, for disk space in case you’re in a Virtual Machine or using a system, anything from 250 GB is great.

1 Like

The lagging might be starting after some update or during file indexing (in KDE baloo does it).

You might want to update BIOS - it may fix some issues and performance.

Main performance issue is caused by HDD, I guess. With probably all devs working on SSDs, no one notices how high iops operations are unbearable on older storage devices. Your best bet would be to buy some SSD, install system on it and use HDD for backup and bigger files. KDE Plasma allows you to easily point e.g. videos, music and pictures folders in your home directory from different drives. That way you have robust system and lots of space for bigger files.

That looks like 8GB of ram with some of it allocated for GPU, that should be enough for internet browsing. Post here output of sudo inxi -ma, if you have one 8GB module, adding another one (even 4GB one) should give noticeable boost in CPU and GPU performance.


thank you :blue_heart:


I actually fixed the issue…I tried updating my bio, then I cleaned my ram slot and it’s running smoothly… I don’t know which one worked, but gosh, its feels nice using the pc without freezing every two seconds and thank you very very much to all you amazing people.


Great to hear

1 Like

Hey folks, I am on GNOME and I am experiencing the same lagging problems in one of the newest Dell laptops I bought a few months ago. All of my other machines on Fedora 36 GNOME are NOT having any problems whatsoever (Desktop + another HP Laptop). All of them are on SSD and not HDD. I am at my wit’s end as to what could be the problem. Here is my output. I would appreciate any help you can extend to me here. Thank you.

  RAM: total: 7.5 GiB used: 6.06 GiB (80.8%)
  Array-1: capacity: 16 GiB slots: 2 EC: None max-module-size: 8 GiB
    note: est.
  Device-1: DIMM A type: DDR4 detail: synchronous size: 8 GiB speed:
    spec: 3200 MT/s actual: 2667 MT/s volts: curr: 1.2 width (bits): data: 64
    total: 64 manufacturer: 80AD000080AD part-no: HMAA1GS6CJR6N-XN
    serial: 255D971D
  Device-2: DIMM B type: no module installed