Fedora 34, spin KDE, extremely slow

I have a desktop and a laptop computers, both very old (about 10 years). For my needs, that’s ok. I only upgrade when things begin not to work. I was perfectly working with Fedora 29 on both until the id-card reader stop to work.
I decided to install the system on a new SSD. Fedora 34, spin KDE, is flying on the desktop computer. It is prompting for the user name in less than 15 seconds. It has 4Gb RAM.
The laptop, with its new SSD and its 8Gb RAM, starts much quicker than before as well (about 40 seconds). But it is desperately slow. Thunderbird crashes when it opens the files browser (= not possible to save or send attachments!). Firefox is almost unusable. The id-card reader works, but makes again the system even slower. Things on text mode seem to work normal (e.g. wget gets podcasts at a perfect normal speed and I listen to radio with mpv also perfectly).
I tried to reinstall from scratch, but the result is the same. I tried the secure mode in both firefox and thunderbird, but it is the same bad. Pidgin is so slow that the answer of my partner arrives before I see the text I wrote appears.
What could it be? Some drivers issue? How can I know e.g. what grafic card and drivers for it I have?
As I said, the computer was working fine with all prior Fedora versions (always KDE) I had.
Thank you for any help!

You can see what hardware is installed in different forms using
inxi -Fxx (full display, other options available)
lspci (various options available)
lsusb (various options available)

You may need to install inxi, but the others are built-in.

Once you have looked at those outputs then if you have specific questions please post the output that puzzles you with the question about it, like this
your output here
Simply copy and paste the output between the code tags as shown and it will retain the formatting you see on the screen so we can read it easily.


One of the big changes in Fedora 34 for KDE users is the switch to Wayland. I don’t think that should cause the issues you are seeing but it is a very quick thing to test. From the login screen, select an X11 session before logging in and see if that makes a difference.

I forgot to add that Wayland was working wrong on both computers, I chose the X11 session.

Here is the output of inxi:

  Host: fedora Kernel: 5.12.11-300.fc34.x86_64 x86_64 bits: 64 
  Desktop: KDE Plasma 5.21.5 Distro: Fedora release 34 (Thirty Four) 
  Type: Laptop System: SAMSUNG product: RV415/RV515/E3415 v: 07PM 
  serial: <superuser required> 
  Mobo: SAMSUNG model: RV415/RV415 v: 07PM serial: <superuser required> 
  BIOS: American Megatrends v: 07PM.M507.20111214.LEO date: 12/14/2011 
  ID-1: BAT1 charge: 17.8 Wh (100.0%) condition: 17.8/48.8 Wh (36.4%) 
  Info: Dual Core model: AMD E-450 APU with Radeon HD Graphics bits: 64 type: MCP 
  cache: L2: 512 KiB 
  Speed: 828 MHz min/max: 825/1650 MHz Core speeds (MHz): 1: 828 2: 824 
  Device-1: AMD Seymour [Radeon HD 6400M/7400M Series] driver: radeon v: kernel 
  Device-2: Silicon Motion WebCam SCB-0385N type: USB driver: uvcvideo 
  Display: x11 server: X.Org 1.20.11 driver: loaded: ati,radeon 
  unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: AMD CAICOS (DRM 2.50.0 / 5.12.11-300.fc34.x86_64 LLVM 12.0.0) 
  v: 3.3 Mesa 21.1.3 
  Device-1: AMD SBx00 Azalia driver: snd_hda_intel 
  Sound Server-1: ALSA v: k5.12.11-300.fc34.x86_64 running: yes 
  Sound Server-2: PipeWire v: 0.3.30 running: yes 
  Device-1: Qualcomm Atheros AR9285 Wireless Network Adapter driver: ath9k 
  IF: wlp3s0 state: down mac: 9a:d0:5d:80:47:e5 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: e8:03:9a:29:b7:10 
  Local Storage: total: 1.38 TiB used: 796.41 GiB (56.5%) 
  ID-1: /dev/sda vendor: Intenso model: SSD size: 476.94 GiB 
  ID-2: /dev/sdb vendor: Toshiba model: MK1059GSM size: 931.51 GiB 
  ID-1: / size: 443.84 GiB used: 9.49 GiB (2.1%) fs: ext4 dev: /dev/sda3 
  ID-2: /boot size: 975.9 MiB used: 260 MiB (26.6%) fs: ext4 dev: /dev/sda1 
  ID-1: swap-1 type: partition size: 24 GiB used: 0 KiB (0.0%) dev: /dev/sda2 
  ID-2: swap-2 type: zram size: 7.75 GiB used: 0 KiB (0.0%) dev: /dev/zram0 
  System Temperatures: cpu: 89.8 C mobo: N/A gpu: radeon temp: 77.5 C 
  Fan Speeds (RPM): N/A 
  Processes: 200 Uptime: 9h 28m Memory: 7.75 GiB used: 3.71 GiB (47.9%) Shell: tcsh 
  inxi: 3.3.03

That system is at slowest cpu speed and it running extremely hot (~90C). The slowdown could easily be due to overheating, either a failing fan, blocked air intakes, or plugged air flow passages. It is also known that having both zram and physical swap space can impact performance.

Speaking of swap. I note that zram is configured as 7.75 GB and did you not say that the memory is only 8 GB? Also the physical swap is 20GB. With only 8 GB memory and 7.75 allocated to zram that by itself can severely limit performance. Fedora 33 by default allocates 4 GB zram max (up to 1/2 memory whichever is less) regardless of the memory size, and on my desktop with 32 G ram and my laptop with 16G ram that 4 GB zram swap is a great plenty. I have no other swap allocated.

Maybe you should try reducing the size of zram to 4 GB and turn off swap on the physical device, then see if it makes any difference.

1 Like

I believe Fedora 34 now allocates 100% of RAM to zram up to 8GB

I agree, 90C for an E-450 seems unacceptably hot if that sensor reading is correct. Perhaps it is throttling.

How can I turn the physical device’s swap off? Anyway there is physical swap too in the desktop computer, and its performance is great.

About the heat, it got always very hot, I don’t know why, but that didn’t affect the performance, the horrible performance just began with the upgrade to F34.

And somebody has any suggestion about why thunderbird crashes when trying to browse files?

There are generally 2 causes of over heating on a laptop.
Air flow can be restricted either by the laptop sitting in a location that blocks the air intake vents, or by a collection of dust/lint inside the air flow passages inside the laptop.
The fan can also be failing, but if you hear it running then that is not as likely.

As has been mentioned, the temp is likely causing the OS to throttle the CPU which will drastically reduce performance. I think if you fix the overheating issue that it will also solve the performance issue.

I switched off, extracted the ssd, mounted the old hdd with the Fedora 29, switched on and everything worked as it used to. Thunderbird could browse files, Firefox worked normal… There was also physical swap there, with no apparent effect on the performance.

Now I am again on F34 with the ssd disc. Gimp needed almost 2 minutes to just get launched. Thunderbird crashes when opening the files browser window, Firefox works like if we were in the 90’s…

So I think we have to discard a hardware issue as such, I think it is more likely that F34 has an issue with the hardware.

When you run the live image do you have the same problems?