Wayland taking up all processor power in fresh workstation 37 kde install

Hello fedorians, i am quite new to using linux. This morning i installed the workstation fedora 37 spin with kde plasma. In the live session as well as after installation the OS was extremely laggy. When i opened up the system monitor it showed a CPU activity between 95-100%, and the processes window showed kwin_wayland taking up my entire processor capacity.

I tried installing htop in order to document the processes activity, but the lag made it really dificult. And i cannot add a picture.

I tried searching the forum as well as google for a solution to no awail. Do you have any suggestions?

Thank you for your time!

Welcome to the Fedoraproject @kriegsaffe

Could you please clarify

There is a workstation who comes with the Gnome-Desktop
The leading Linux desktop | The Fedora Project

Or the KDE spin who comes with KDE-Plasma installed already.
Fedora Spins | The Fedora Project

Just that we do get the right picture of what you exactly mean.

Anyway, have you updated after installation?
sudo dnf upgrade

And also from interest could be your GPU:
inxi -G

Inxi -G shows:
12Graphics:
12Device-1 NVIDIA TU117GLM [Quadro T400 Mobile] 12driver nouveau 12v kernel
12Display wayland 12server X.org 12v 1.20.14 12with Xwayland 12v 22.1.7 12compositor kwin_wayland
12driver N/A 12resolution 3840x2160
12API OpenGL 12v 4.5 Mesa 22.3.4 12renderer llvmpipe (LLVM 15.0.7 256 bits)

I updated and upgraded without resolving the issue.

And i have installed the fedora KDE plasma desktop spin with KDE preinstalled.

Thanks!

Have you checked to see if you can log in using xorg to see if there’s a difference.

Is there with X11 no Wayland involved ?

Alright, i logged in using xorg11 instead of wayland and KDE now runs smoothly with a CPU activity of between 2-3%. I did not know that switching this easily was an option. Thank you!

If you where in my shoes, would you report this? Will the developers benefit from this knowledge?

Glad you have it working now.As far as reporting it the more issues reported the better.Maybe they will get the issues worked out in time but KDE seems to not play well with wayland.

That tell me that all graphics rendering is forced to the CPU since the nouveau driver does not support hardware acceleration on an nvidia GPU.

I expect you would see a major difference in cpu usage if you were to install the nvidia drivers from rpmfusion which would enable hardware acceleration and support wayland on that GPU as well.
The T400 GPU appears to be supported by the latest nvidia drivers as well.

2 Likes

Alright, i just installed the nvidiadrivers from rpmfusion and switched back to wayland. Everything is running smoothly and the inxi -G command shows:

Graphics:
Device-1: NVIDIA TU117GLM [Quadro T400 Mobile] driver: nvidia v: 525.85.05
Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 22.1.7
compositor: kwin_wayland driver: N/A resolution: 3840x2160
API: OpenGL v: 4.6.0 NVIDIA 525.85.05 renderer: NVIDIA T400/PCIe/SSE2

System monitor shows a base CPU activity of 0-5%

Thanks a million everybody!

5 Likes