Fedora 35 where are SRPMS ? ( dnf builddep )

sudo dnf builddep wine
enabling fedora-source repository
enabling fedora-modular-source repository
enabling updates-source repository
enabling updates-modular-source repository
enabling rpmfusion-free-source repository
enabling rpmfusion-free-updates-source repository
enabling rpmfusion-nonfree-source repository
enabling rpmfusion-nonfree-updates-source repository
Fedora 35 - Updates Source                      809  B/s | 150  B     00:00    
Errors during downloading metadata for repository 'updates-source':
  - Status code: 404 for [MIRROR]/fedora/updates/35/Everything/SRPMS/repodata/repomd.xml (IP:
Error: Failed to download metadata for repo 'updates-source': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried`

Red Hat Mirror:
download-ib01.fedoraproject.org/pub/fedora/linux/updates/34/Everything/SRPMS/ exists
download-ib01.fedoraproject.org/pub/fedora/linux/updates/35/Everything/SRPMS/ gone?
How to use “dnf builddep [PACKAGE]” on Fedora 35?

Hmmm — it looks like there should be a link named SRPMS pointing to source/tree in the same directory, but there isn’t for F35. But, the normal mirrormanager metalink is pointing at source/tree

Have you reconfigured your /etc/yum.repos.d/fedora-updates.repo file at any point? The reason I ask is that the default has these lines:

name=Fedora $releasever - Updates Source

Note that “baseurl” is commented out. That’s an older syntax, which points to just one mirror. The “metalink” line points to an xml document which will give you a list of (hopefully near-to-you) active mirrors. And I just checked, and the URLs that gives back (curl -s 'https://mirrors.fedoraproject.org/metalink?repo=updates-released-source-f34&arch=x86_64') contain source/tree, not SRPMS.

It looks like there’s an error on the infrastructure side — that link should be there for compatibility. And possibly we should also update the example line to point to the source/tree subdir as well.


Thank you Matthew, i use mirror site in old syntax, according to mirror site guide.
“dnf builddep” works again after i restored original .repo files.


Cool, glad that worked. Where is the guide you followed? Maybe we can get it updated…

Nearly all CN mirrors from here admin.fedoraproject[DOT]org/mirrormanager/mirrors/Fedora/35/x86_64 , except mirrors.163[DOT]com , are using old syntax guide.