Fedora 34 x86_64 USB Drive Boots in UEFI but Won't Run

I have not built a computer for many years and was puzzled to encounter problems with UEFI booting. I’m totally unfamiliar with UEFI and Grub2. I am able to access the grub terminal on my Live OS USB drive, but will require step by step instructions to make sense of your advice. Thanks!

I just assembled a new computer with a Gigabyte B550 Aorus Master ATX motherboard and an AMD Ryzen 7 5800X Vermeer 8-core AM4 processor. I am using the Fedora 34: x86_64 DVD ISO. I have not yet updated my BIOS.

I have a SATA HD that already has Fedora 34 installed on it, but I believe it is a legacy boot installation. It is from a different computer that has an Intel i5 CPU and a MSI motherboard from 2013. I do not expect to get it working, but it may still work because it now offers an option to configure UEFI settings when it boots in UEFI mode. Selecting this takes me back to the BIOS.

I also have a Fedora 34 Live USB. I prefer to overwrite the SATA drive with a fresh install of Fedora 34 in UEFI mode. I’m trying to boot it in UEFI mode and reinstall a compatible version of Fedora. The problem is that the USB drive appears to stop working at the same point where the SATA drive stops working.

I get a blank screen after selecting the Live OS or to Test Media. I can reach the point where you would see scrolling text before the Live OS loads the GUI. I have left the computer sitting for 30+ minutes and the Live OS never loads.

I am able to access the grub terminal but am unfamiliar with how to use it.

I have tried repairing the Live OS install and recreating the live USB without the Cinnamon spin I had been using. I have noticed that I am trying to install the x86_64 version of Fedora 34 in Fedora Media Writer. I’m given choices between Intel 64 bit, Intel 32 bit, ARM v7, and AArch64.

Since I am using an AMD chip, will the x86_64 version of Fedora not work? I did not think it was specifically for Intel, but its name in Fedora Media Writer makes me think that it could be.

My BIOS settings are flexible and continue to be reset to default configurations every time I try something new. Here’s what they were last time.

Bootup numlock state on, Fast Boot disabled, Security Option set to system. I’ve read some advice that says to disable secure boot, but the choices I have are between system and setup. There is no option to disable.

CSM Support enabled. Disabling CSM support makes the following options disappear. LAN PXE Boot option disabled, Storage Boot Option Control set to UEFI only, Other PCI Device ROM priority set to UEFI only.

Any advice on how to get Fedora 34 installed on my new PC?

Maybe it is a problem with the video driver. Does it work if you add nomodeset to the list of kernel parameters?

1 Like

Hello and thanks for your reply!

Could you or anyone explain the process of adding nomodset to the list of kernel parameters? I would need to know how to do that from the grub command line.

You have given me an idea, though. I will try running the installation without the graphics card. I’ll return and let you know how it goes after I finish at work.

It appears to be documented here:

It looks like you press the E key, edit the parameter list for the Linux kernel, and then press Ctrl+X.

Hi again. I’m afraid I don’t fully understand the documentation. I have no experience with grub or with modifying boot processes in general. The kernel is something I do not modify manually.

5.4.2 seems to be the relevant section of the documentation. After reading it, I do not understand the process of how to “edit the parameter list for the Linux kernel.”

Examples I’m seeing look like this: grub> <kbd>linux /vmlinuz root=/dev/sda1 acpi=off</kbd>

and grub> <kbd>linux /vmlinuz root=/dev/sda1 acpi=off</kbd>

What exactly is the process of editing the parameter list for the kernel? I do not know how to access it from the grub terminal, do not know which folder it is in, do not know how to edit the list from the terminal, etc.

It’s been a while since I’ve used grub myself, but I think it goes something like this:

  1. Press the Esc key when booting to see a list of kernels (this is the grub boot menu)
  2. Highlight the kernel you want to use.
  3. Press the E key to edit the selected menu entry (should show something that looks like a text file editor loaded with lines of code).
  4. Arrow down to the line that starts with linux ... (this is the point in the code that loads the kernel and passes the parameters).
  5. Arrow over to the end of the line and add a space and then whatever parameter you want to add (in this case, that would be nomodeset).
  6. Press Ctrl+X to “execute” the modified boot entry (the modification is temporary; it will not persist across another reboot).
1 Like

Thanks for all your help! After trying a lot of different things, I found that your intuition about the graphics drivers was correct, but the issue ended up having little to do with Fedora.

I was trying to install a UEFI version of the OS on a motherboard with out of the box BIOS firmware. Upgrading the BIOS solved all of my problems.

This was because the motherboard I have didnt include support for slightly older (2017-2019) graphics cards or even older (2015-2016) hdmi monitors/televisions.

Thanks again for your help.