Fedora 34 Crash on system idle

Good Afternoon,

A little bit scarce on detail but the same problem when I tried to update to a previous version of Fedora. On ASUS ZenBook u533f workers correctly on f31 for a long time but after upgrade, I believe it was f32 I tried previously, now with f34 same problem, when computer goes idle it reboots. I can watch the screen go dark like usual and then self reboot. If idle is not activated it is stable for many days.

I am able to assist with information if somebody wants to prompt what information?

I have checked that on f34 the problem goes away if disabling both Dim Screen and Blank Screen in settings. This has been a problem since f32 and was previously resolved by reverting to f31.

Please post back if anyone is working on this, if there is a resolution.

I have checked that on f34 the problem goes away if disabling both Dim Screen and Blank Screen in settings.

Not actually a complete solution but it is better.

It would be useful if anybody reqadds these new forums. The old forums used to be helpful. The problem still exists if the computer il left locked.

This is still not resolved.

1 Like

Hi there, can you enable idle and trigger the isse?
Them post your error logs, e.g. with a command like this:
sudo journalctl -p crit --since +3d
(Assuming you would like to post all critical errors from the last 3 days.)

I triggered the issue simply by locking and waited for it to reboot after the screen idle power off, and after reboot:

$ sudo journalctl -p crit --since +10d
-- No entries --

Would you like to post the result of cat /sys/power/mem_sleep?

Also when I check your laptop specs, look like it uses nvidia card. If your system have nvidia powerd service, please also check with systemctl status nvidia-powerd.service.

Yes, the second video is nVidia. I have no special drivers installed. If it wasn’t clear the issue occurs when the screen blank is activated and has been in several version of Fedora, I did hope it would be resolved in Fedora 34 with the changes.

$ cat /sys/power/mem_sleep
[s2idle] deep

$ systemctl status nvidia-powerd.service
Unit nvidia-powerd.service could not be found.

$ cat /sys/power/mem_sleep
[s2idle] shallow

The above is the output in my Terminal. Can this help you?

If you know where that can be entered as a setting. As it is, I ended up with setting blank screen to never but if I use Lock it dims anyway and then it reboots.

But I suggest you to upgrade to F36.

If you are still on fedora 34, be aware that fedora 34 has been EOL for some months and gets no fixes, upgrades, etc. from the date it went EOL.

If you need to solve problems it is strongly suggested you upgrade to the latest (fedora 36) so updates remain current and the latest fixes may be installed.

That is all very competent advice.

The file does not allow to be saved even as root.

Thank-you for looking, you can see this was reported a Year ago. I don’t mind upgrading but if I report and nothing is done until support is closed I suppose I might wait until the issue is fixed.

Earlier probably, this is the second report.

No bug fixes, no anything else being done for F34.

Yes, but if it is fixed in the new version? No-one can really be bothered upgrading I upgraded from Fedora 31 to get better video support, and again to see if the bug was fixed. Anyway, if I do.

As far as this question concerned, I’m running F36 and have no such issue. I was having similar issue with Ubuntu few years ago. So I guess the issue is more connected to Kernel version, than the packages. So by upgrading to latest version not only keeps your system latest on OS, but also, many bugs fixed. If you have any special cases to consider while upgrading, you may contact the Fedora support.

That certainly is your choice. If you do not update then you have chosen to keep your system as-is with any bugs & problems that you currently have. Upgrading allows kernel updates, bug fixes, and new features to be installed and active.

1 Like