Fedora 33 KDE Live USB Boot Hangs

I have a compute-intensive application that I’d like to use an old Poweredge 1800 server’s CPU’s to run some copies of the app with. Since it hasn’t been powered on in quite some time, I apparently cannibalized it, removing the boot HD that it had. Now, I’m trying to get Fedora installed on an extra HD that I had laying around, but am having issues getting the F33 KDE Live UDB stick (that I have booted in the past on other PC’s) to work. I do end up getting the initial menu to start up, but when I choose to start the Live image it just hangs after vmlinuz and initrd are loaded - with a grey screen if the quiet boot option is used, or a blank screen with the cursor in the upper left corner without it. This is regardless of whether I use nomodeset. I have now spent 2 days trying every option offered by my favorite search engine to no avail. The CPU is a Xeon that I have confirmed (in and of itself harder than it should have been) is 64-bit. The graphics processor is an ATI Radeon 7000-M.

Any ideas how to get this to boot the live image?

I really do not have any other media options available, nor can I use the hard drive that I have available for this in any of my current systems (otherwise, I’d do the install there and move the drive). I really do not care what version of Fedora that I use, so if upgrading or downgrading will work, I’m OK with that. (I’m looking to stick with Fedora because I have been using it since before it was called Fedora and know it pretty well.)

I was thinking PXE boot, but I really, really do not want to change the DHCP server that I’m using for various reasons and am having issues trying to get dhcpd to run only as a PXE server even though it’s my understanding that the two are separable according to the spec (I guess another thread…).

Any suggestions would be greatly appreciated.



I don’t know for sure, but is that old machine really 64 bit? Fedora 33 does not have 32 bit kernels and only will work on 64 bit hardware. Sometimes the processor may support 64 bit but something else limits it to 32 bit on those old machines.

Maybe you could check that by booting to a fedora 32 or earlier live image. Older images are available here.

Reading the info online it appears to be 64 bit capable, but with a 2012 machine, who knows for sure. The issue also may be driver related.

If the LiveUSBs do not work with nomodeset, I will try to install in Text Mode.

Thanks to both for the suggestions.

First, according to https://ark.intel.com/content/www/us/en/ark/products/27094/64-bit-intel-xeon-processor-3-00e-ghz-2m-cache-800-mhz-fsb.html, it is a 64-bit instruction set, but I tried 32 bit versions as well.

As far as things I have tried since my original post, I tried F31 x86_64 (there was no i386/i686 version), F25 i386, both KDE Live and neither worked.

I then ran across my past install notes for the machine. According to those, I installed F16 on it back in 2012 with the netinst version without issue, but that was by burning a CD and booting that. I no longer have a CD writer. My next upgrade was to F22. My notes said that I couldn’t boot the install media, and that I used a VM to install the upgrade on the desired disk partition. Unfortunately for my current situation, I could do that because I had a running machine (running F16), which is not the case now. So I tried to install F16 (both 32 & 64 bit and both KDE Live & netinst) from a USB drive with no luck.

In at least one of these attempts, I tried text mode as well, along with inst.resolution=800x600 and inst.usefbx, each in combination with and without nomodeset, none bringing joy.

Can someone tell me what happens in the first minute or so after the initrd code is loaded by the boot loader? That is when it hangs. As an aside, after it hangs, if I type a key, the system beeps. Not sure if that is meaningful…

In the meantime, I’ll see what other ancient stuff I have laying around that might be of some help.

Again, thanks for trying to help!


You have said all the installs you tried have been kde. Trying the default gnome install may give different results, as it may be a video issue.

No, they weren’t all KDE. Two were net installs (netinst in the image name), including the F16’s which worked once, long, long ago… But thanks for the suggestion anyway.


My comment about the video issue still stands, although your attempt to do a text install makes that less likely. Have you by chance tried running memtest86 on it to verify the processor and memory are good?

If textmode install do not help, next to try is VNC remote.