Fedora 31 Workstation KDE Desktop from Spins can print but can't find the scanner of Brother MFJ-J430W

How can I activate the scanner of such multi-function device ?


Look if this can help you



I used this driver for the device model that I have.

The Document Scanner found only the camera of the notebook.

Hi i visited your link and i go to this version
brscan4-0.4.8-1.x86_64.rpm Do it be different due to others languages or regions?

Is your multi function print connect via USB or NET (did you check the step number 4 from the page of installation?

Yes, it is connected to notebook via USB cable and the driver is ‘English’.
And it can print, except scan.

It looks like you are trying install the driver install tool that is the best option.

If i try run this software i go to this (I need indicate the model, I don’t know if you could run this without problems

Step6. Run the tool:

Command: bash linux-brprinter-installer-..- Brother machine name
e.g. bash linux-brprinter-installer-2.1.1-1 MFC-J880DW

Step7. The driver installation will start. Follow the installation screen directions.

When you see the message “Will you specify the DeviceURI ?”,

For USB Users: Choose N(No)
For Network Users: Choose Y(Yes) and DeviceURI number.

The install process may take some time. Please wait until it is complete.

If you could install the tool without problems maybe it should be good contact with their support to report them the issue.

I did look into the drivers included by default in my f31 to the brothers prints and i couldn’t find your model.

Note than the image is only a extract of all listed.


I used 2.1.1-1, which was wrong.
After using 2.2.1-1, it is OK.
Thank you so much.

1 Like

I just went down this road on the Fedora 32 KDE spin, but it is now solved!!

I found several forum posts on the subject, as I am a new user I can only post two links (anti spam measure)

This for a Cannon suggesting it could be firewalld, in my case it wasn’t a firewall issue-but this might be your issue - it’s worth a read at any rate

But finally my issue was solved here which is a link to the old fedora forum. Thanks to @lzap for the solution!! I hope he doesn’t mind me sharing it here on the new forum.

Blockquote First, I am going to use simple scan utility, it also needs a dependency package which somehow is not correctly listed in Fedora 28, so install these two guys:

dnf -y install libnsl simple-scan
Then download brscan4 and brscan-skey RPM packages from Brother site and install both. For scanning you only need brscan4 actually, but I installed both. Some tutorials also guides you to install package named brother-udev-rule-type1-1.0.0-1.noarch.rpm but you won’t need it as it was merged into brscan4 package.

Brother RPM packages are known to have lame scripting, their scripts usually don’t work in different environments. After installation check that the following file exist: /etc/udev/rules.d/50-brother-brscan4-libsane-type1.rules and if not fix the installation script /opt/brother/scanner/brscan4/udev_config.sh.

Also check that the file /etc/sane.d/dll.conf contains brscan4 line, if not add it or fix their script /opt/brother/scanner/brscan4/setupSaneScan4:
sudo su (for this next command)
echo brother4 >> /etc/sane.d/dll.conf
This was not working in my Fedora 28 in package brscan4-0.4.5-1.x86_64.rpm at all.

Then visit printer’s built-in web interface and configure it for static IP. You can do the same on your DHCP server if you prefer to.

And then - aaarghhh - the hidden trick which caused me the headache:

sudo brsaneconfig4 -a name=PRACOVNA model=MFC-L2700DW ip=
And done! Switch over to “Brother *PRACOVNA” scanner and you can scan over IP. I use “simple-scan” which is quick and nice tool that aims for easy scanning into PDF with multiple pages support. Highly recommended.

Sorry about the block quote formatting being a bit ugly. There are several answers on that forum thread and I wanted to make it clear which solved my issue, as the top comment didn’t do the trick, it’s further down the page. I really hope this helps someone. Maybe someone reading this from the Fedora project community has some weight with Brother and could encourage them to update their install script or make a separate rpm offering for Fedora? We can always hope :wink:

I followed the steps from that answer and it got simple scan to work with my Brother MFC-L2750DW
The printer driver rpm I used is linux-brprinter-installer-2.2.1-1

Here is a dump of my relevant bash history:

 176  dnf search sane
 177  dnf search sane --installed
 178  man dnf search
 179  sudo dnf install libnsl
 180  dnf info libnsl
 181  sudo dnf install libnsl2
182  sane-find-scanner
 183  sudo sane-find-scanner
184  scanimage -L
185  ls /dev
186  dnf list --installed sane
187  dnf list sane
188  dnf list sane*
189  sudo dnf install sane-backends
190  sudo dnf install sane-backends-drivers-scanners
191  sudo dnf install sane-frontend
192  sudo dnf install sane-frontends
193  sudo dnf install sane-backends-daemon.x86_64
194  scanimage --list-devices
195  sudo dnf install -y xsane
196  sudo dnf -y install libnsl simple-scan
197  history | grep installed
198  dnf list --installed sane
199  dnf list --installed sane*
200  dnf list --installed brscan*
201  ll /etc/udev/rules.d/50-brother-brscan4-libsane-type1.rules 
202  cat /etc/udev/rules.d/50-brother-brscan4-libsane-type1.rules 
203  cat /etc/sane.d/dll.conf
204  cat /etc/sane.d/dll.conf | less
205  ll /etc/sane.d/dll.conf | less
206  cat /etc/sane.d/dll.conf | grep brother4
207  cat /etc/sane.d/dll.conf | grep pixma
208  sudo echo brother4 >> /etc/sane.d/dll.conf
209  sudo su
(then run that echo command again and exit)
210  cat /etc/sane.d/dll.conf | grep brother4
211  brsaneconfig4 -a name=Brother model=MFC-L2750DW ip=
212  sudo brsaneconfig4 -a name=Brother model=MFC-L2750DW ip=

Hope this helps!

1 Like