KDE Fedora 31 Simple Scan can't find Canon Pixma Multi Scanner

I have a Canon Pixma MX 922 wifi multi function. Works flawlessly with Gnome Fedora 30 but for some reason KDE Fedora 31 can’t find it. Any ideas would be greatly appreciated. I’ve tried hard wiring to no avail. The printer portion works fine, just the scanner won’t show up. Thanks in advance

1 Like

Can you please grab a Fedora 31 workstation live image and see if it works there?

If it does, then we simply have to figure out what package is missing in the KDE install that includes drivers for your scanner.

Thank you for your response. I actually started with Fedora 31 Work Station but could only get it to install in safe mode so I decided ultimately to just download KDE 31 because I didn’t want the Gnome bloat anyway, and it installed fine. Anyway, the Gnome version found the scanner flawlessly as it did the printer.


OK, are you using Simple Scan on both? This implies that some package that gets installed by the Gnome/Workstation is not part of the KDE installation.

This was actually an afterthought – more random then not – but I’ll ask it first as it’s a simpler one to answer to. @reno232, please provide output of

sudo firewall-cmd --get-default-zone

and also please tell if you by any chance made some changes to your firewall configuration.

One other possibility (aside of missing packages, I mean) would be that MFU setup process in Gnome correctly sets up your device both as printer and as scanner when its KDE counterpart for some reason doesn’t do scanner part.

I’ve dealt with Brother and HP MFUs but not Canon ones. Setup of HPs one involves using hplip – special program to correctly setup HP devices. Setup of Brother one involves installing some packages provided by brother and then configuring networked scanner.

Can you describe a bit setup process you’ve followed both in Gnome Live session and in KDE?

One other thing to try is to check output of this command in both environments:

scanimage --list-devices

(though manual says it may not list networked devices). It lists both of mine though…

I checked the firewall as part of my process and there was nothing there. I made no changes there at all.

With 31 Gnome, it automatically finds the scanner, I simply open simple scan and it finds it. The printer I still need to add through “add printer” but that’s easy with no problems. The same can be said via KDE 31 on the printer side, but with the scanner, when it searches it doesn’t find the Canon, just a USB2.0 VGA UVC WebCam: USB2.0 V virtual device

Likewise, scanimage finds nothing on KDE, but does on Gnome.

All that being said, I’ve decided it best to just go the Gnome - install KDE desktop route. For me it seems a little more stable and fluid. I simply delete all the Gnome and KDE bloat.

The one big issue i have, big being a relative term, is that in Gnome, some of the desktop effects are missing, I notice I can’t get some of the desktop effects such as magic lamp, fall apart, and wobbly windows. They don’t even show in the list in desktop behavior-desktop effects unless I go to configure filter, uncheck exclude desktop effects not supported by the compositor, then they show and I can choose them, but it won’t allow me to save them, thus making them inoperable. Any ideas?

@reno232, can you run this command on KDE install and provide an output here, please?

Unfortunately, I just completed installing 31 Gnome so KDE is gone except as the desktop environment. BTW, the results were the same for the Xsane app, works without doing anything in GNOME, nothing for KDE.

Well, in this case the question is sort of closed – though not resolved.

My thinking was this. Your MFU should be using sane-pixma backend, and for it to autodetect network scanners it needs port 8612 open. It all documented here:



I know for sure all ports above 1024 are open in Fedora Workstation edition (with Gnome). This corresponds to the sudo firewall-cmd --get-default-zone reporting FedoraWorkstation as default zone.

If by any chance KDE spin choose to use another firewall zone by default (public, for example), then port 8612 could be closed by default – thus preventing automatic discovery of your networked MFU under KDE.

We need someone using KDE to confirm or dismiss this guess of mine.

By the way, the link I’ve found (above) describes a way to specify your MFU manually in case autodetection doesn’t work – look for subsection ** /usr/local/etc/sane.d/pixma.conf*.

I think this is due to Gnome compositor (called mutter) not supporting desktop effects such as wobbly windows. AFAIK you can’t use wobbly windows under Gnome currently (and for a quite a long time now). Gnome2 running under compiz supported them quite some time ago.

Man you are all over this stuff. Quite impressive. If I ever decide to go back to KDE 31, I’ll try this.

In regards to the Gnome Compositor, it’s kind of weird that it wouldn’t support the effects, yet have it as an option, albeit not executable. As stated, one can uncheck “exclude desktop effects not supported by the compositor” yet not be able to save it. Yet another Linux nuance I guess. This is perhaps the reason so many go distro hopping, perhaps myself included, all this seemingly silly stuff. If it works under KDE, it should reasonably work under their desktop environment, or at the very least, exclude it as an option.

I believe the options you describe are from (and for) KDE desktop as I don’t see anything called desktop-effects on my Gnome installation.

If they are not working under KDE either – then it may be due to fact that KDE can use several different compositors as far as I know, and it could be that currently selected one doesn’t support them – but they will work if KDE is running under another compositor.

You have to install the KDE desktop:

Sudo dnf install @kde-desktop-environment

You should check it out. Once installed, at boot up, you simply choose which environment you want to work under before putting in your passcode.

You’re probably correct though as to the reason it’s not working. I wonder if there is a way to communicate to them there are many of us out here that would love that option available?

Well, I’ve gone back to KDE. I’m just dealing with some of the issues. However, in returning to this issue, I ran sudo firewall-cmd --get-default-zone as requested and it indeed came back “public” as you guessed it might.

1 Like

Thanks for reporting it, @reno232!

In such a case the solution should be (according to the docs I’ve linked to) to open a port 8612 in a firewall. This can be done either using GUI or cli commands.

The good how-to is here:


Although I’d advice to make a new firewalld service instead of directly opening the port. With service it’s easier (1) to transfer you config to another machine and (2) to remember, what for have you opened this port. It’s easy to do with the GUI quickdoc describes.

I’ve also written this short how-to about how I do it on a server without a gui here:


1 Like

So, if I wanted to use the Firewalld GUI would I use the steps Delacosta laid out? Should I keep the default zone as public?

You can start with the steps from this post (I think that’s the same one you’re referring to):


With one difference. He modified existing service, whereas I suggest to make a new one. So on step 4 instead of selecting exiting service you need to press a plus button (under the services list) to add a new service, then fill the fields required (service name is needed, and I suggest a comment to help you remember what is it for in the future) – and then proceed with adding port per @delacosta78’s instructions.

This is actually a rather interesting question. :wink: Me personally – I would leave it as public, and this is what I actually have on all my Fedora machines. KDE spin developers too think the default should be public.

Developers of Fedora Workstation (“default” version with Gnome) think that FedoraWorkstation zone is a better choice – being an easier one for inexperienced users. It was a topic of several (to date) rather heated discussions on a mailing list. I personally don’t agree and change my settings to public first thing after installing Fedora.

So you have decide for yourself ) Public is definitely more work on your part – but more secure. Although people that are against it make an argument that actual increase to security is negligible – I do disagree with that point of view.

If you want less hassle – you can switch to FedoraWorkstation zone by default. I can provide some additional arguments for both sides of the question :slight_smile: – but later. If you need them )

Thanks again for all your help Nightromantic. I tried the steps set forth to no avail. I then changed the default zone to Fedora Workstation and the scanner now works. You were a big help. Thanks again.

1 Like

At least we know for sure the firewall was the reason.

Well, this is exactly the hassle I was talking about ) It should be quite easy to troubleshoot though ) The hardest part would be if the scanner needs some other ports open as well… but it’s doable )

1 Like

As long as I have you here, I do have two other issues that perhaps I should just open another thread on, but here goes. When I reboot, it asks me to enter the wifi passcode every time instead of remembering it. Any ideas?

Yes, please start a new thread for this (and mark the appropriate post in this one as the solution).