Fedora 31 hangs during boot sequence after updating

Hello, I’ve updated my Fedora 31 from kernel 5.3.12 to 5.5.7. It was a really big update so probably a lot more stuff was installed than I realized. What’s happening is that I get stuck on the boot sequence on the “Started Login Service” line and I cannot make it move forward as can be seen in the following photo.

By using Alt+Fx I can use a regular terminal and login. However, I’ve got no idea on how to fix this

I’ve read some threads online and experimented with installing Kernel 5.5.8 from a testing repository but it stayed the same. I actually went back and selected the previous kernel from the list which appears on startup and the same result happens (which makes me suspiscious if this isn’t about the kernel but about something else). I think this may be related to the nVidia drivers as my build is the following:

  • CPU: AMD Ryzen 2700X
  • Motherboard: MSI B450 Tomahawk
  • GPU: nVidia RTX 2070 Super

Maybe something GPU related updated and now broke my configuration? I think these new GPUs have been very problematic under Linux.

Any help on solving this would be greatly appreciated or else I’ll have to try to re-install Fedora or some other distro :pensive:

  Hi.  Probably LTS-one distro, but it maybe not fly too.  I’d once tried Ubuntu-LTS with this particular laptop of mine (m. 2013-th year) and the p-blob:  fail.
  Or do you use the nouveau driver?

  Do graphics works?

Hello @vits95 I think I use the nouveau driver. Not completely sure. How can I check? I remember I had access to some nVidia application kind of similar to the nVidia control panel in Windows.

Here’s my journalctl -b and fpaste results. Hope this helps solve the issue.

   “rd.driver.blacklist=nouveau” in journalctl.  To know for sure there is lspci -v command (find your GPU and check its “Kernel driver in use” line).

Xorg modules … glx nvidia fb wfb ramdac

   No, this is rather Nvidia one loaded (fpaste).

# ?
dnf list --installed |grep nvidia

   Xorg has been crashed (journalctl):

Xorg errors (fpaste)
Failed to initialize the NVIDIA kernel module

change to rd.driver.blacklist=nvidia (from nouveau).  See if this works now (it rather will, as nvidia module somehow not work, if even present).  Changes maded in GRUB menu during boot aren’t permament.

I ended up fixing this by uninstalling the nvidia driver and installing a more recent one. For anyone wondering I used this guide.

1 Like