Fedora 31, dual boot: no Windows(r) entry

I have installed fedora 31 as a dual boot alongside windows, and now windows is not showing up in the grub. I had Kali installed before with a separate /home partition so I just put that on a liveUSB and decided to install fedora over the old system, and everything went fine except that I can’t boot into Windows as there is no option.

I have tried many many things to fix this but nothing has worked. here is a list of what I remember I have done:

  • I made the grub visible by default
  • I set BLSCFG to false
  • I used os-prober both before and after mounting all partitions and just the windows partition
  • I installed and reinstalled shim
  • I installed and reinstalled grub and grub2
  • I reinstalled fedora31 and then did it all again
  • Tried reinstalling just the efi partition.

I have no idea what to do now. The grub picked up windows in Kali.
Please help

  Hi.  You better wait for someone other to answer.  But either way:  First, install Kali again (only a Win's grub-config generated during the installation is actually needed), as it has worked for your case.  Then find where Kali's grub put the Win'dows menu-entry for GRUB.  And then post this file contents there.


Does os-prober discover your Win installation? Have you tried to do regenerate the Grub config afterwards?

grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

Not sure what exactly you mean with that but it could be a problem that you wiped away the windows boot loader.

What doesefibootmgr say?

Generally helpful (make sure to consider the EFI instructions only): https://docs.fedoraproject.org/en-US/quick-docs/bootloading-with-grub2/

1 Like