Fedora 30 can not find other monitor

I am troubleshooting a second monitor issue on my laptop. I recently upgraded my P51 to Fedora 30. The upgrade went well and plugging in a second monitor to the HDMI port worked well also. Recently, the second monitor is no longer detected when I plug it in and I cannot point to any specific change that may have caused that since I do not always have a second monitor connected. The laptop primary display works fine.

To check if it was a hardware or software issue, I rebooted to Windows – no problem with the second monitor there. I also booted a Fedora 30 install USB stick and the second monitor works there as well. This leaves me with the idea that the currently installed Fedora 30 cannot/does not detect the monitor on the HDMI port and that the problem lies therein.

My question is what should I do to figure out what problem is and how do I fix it? I have spent the last several days searching out solutions via Google etc. So far nothing works. I’d rather not reinstall Fedora if I can fix what is not working properly. Everything else with the Fedora 30 works well, it is just the inability to use the second monitor that is broken. While I have back ups of my files, a reinstall seems overkill and does not help me learn anything new.

Below I am posting the output from a few diagnostics. I hope some of this will provide a clue for a path forward.

[ben@strathy-pypes ~]$ xrandr -q
Screen 0: minimum 320 x 200, current 3840 x 2160, maximum 8192 x 8192
eDP-1 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 345mm x 194mm
   3840x2160     60.02 +  60.00    60.01*   59.98    59.97  
   3200x1800     59.96    59.94  
   2880x1620     59.96    59.97  
   2560x1600     59.99    59.97  
   2560x1440     59.99    59.99    59.96    59.95  
   2048x1536     60.00  
   1920x1440     60.00  
   1856x1392     60.01  
   1792x1344     60.01  
   2048x1152     59.99    59.98    59.90    59.91  
   1920x1200     59.88    59.95  
   1920x1080     60.01    59.97    59.96    59.93  
   1600x1200     60.00  
   1680x1050     59.95    59.88  
   1400x1050     59.98  
   1600x900      59.99    59.94    59.95    59.82  
   1280x1024     60.02  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1440x810      60.00    59.97  
   1368x768      59.88    59.85  
   1280x800      59.99    59.97    59.81    59.91  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   960x540       59.96    59.99    59.63    59.82  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   700x525       59.98  
   800x450       59.95    59.82  
   640x512       60.02  
   700x450       59.96    59.88  
   640x480       60.00    59.94  
   720x405       59.51    58.99  
   684x384       59.88    59.85  
   640x400       59.88    59.98  
   640x360       59.86    59.83    59.84    59.32  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32    56.34  
   432x243       59.92    59.57  
   320x240       60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32  

[ben@strathy-pypes ~]$ lspci -v  */ just the graphics cards here for brevity */
00:02.0 VGA compatible controller: Intel Corporation HD Graphics P630 (rev 04) (prog-if 00 [VGA controller])
	Subsystem: Lenovo Device 224d
	Flags: bus master, fast devsel, latency 0, IRQ 131
	Memory at 2ff2000000 (64-bit, non-prefetchable) [size=16M]
	Memory at 2fc0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at e000 [size=64]
	[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: i915
	Kernel modules: i915

01:00.0 3D controller: NVIDIA Corporation GM206GLM [Quadro M2200 Mobile] (rev a1)
	Subsystem: Lenovo Device 224d
	Flags: bus master, fast devsel, latency 0, IRQ 255
	Memory at eb000000 (32-bit, non-prefetchable) [disabled] [size=16M]
	Memory at c0000000 (64-bit, prefetchable) [disabled] [size=256M]
	Memory at d0000000 (64-bit, prefetchable) [disabled] [size=32M]
	I/O ports at d000 [disabled] [size=128]
	Expansion ROM at ec000000 [disabled] [size=512K]
	Capabilities: <access denied>
	Kernel modules: nouveau

Thanks in advance for any help,


Hi all,

I ended up doing a complete reinstall to fix it. All OK now, but I still don’t have any idea about what went wrong or how to fix it.



Hey I know this is old but I had the same issue today with Fedora Silverblue 33 Beta. During my research I found this thread, so I thought I’ll leave my solution here.

I was able to fix it without a reinstall. The problem was, that I tried GNOME on Xorg and forgot about it. Once I switched back to Wayland and rebooted, everything was again working as expected.

Maybe this helps someone :slight_smile:

1 Like

You are using F30 which is no longer supported.
I would suggest that you upgrade to the current Fedora 32 (or wait a couple weeks and upgrade to Fedora 33 when it is released) and see if the problem still exists. It then would be easier to troubleshoot.

This tells me you are using the default nouveau driver for an nvidia card. You could try installing the dedicated nvidia drivers from rpmfusion and see if that fixes it. The rpmfusion guide tells how.

I’m experiencing this now on f38 in April 2023. I’ll try rebooting and choosing different windowing sessions. Somewhat reluctant to clean install, but maybe that is an option.
The computer detects something when I plug in the HDMI cable, but it is not recognizing it as a monitor.
Any suggestions on how to troubleshoot are appreciated.

You should not be reopening a thread that has been dead for 3 years and 8 release versions.
I am closing this thread and suggest that you instead open a new topic and provide details as to what your hardware is and what is happening. Everything related to graphics has been updated or replaced in the intervening period…