Feature image creation

Can someone tell me if there are any “gotchas” in the Feature Image creation process listed here:
https://pagure.io/fedoramagazine-images
I have followed the process at least 4 times from the top looking for my error but I can’t find.

I get through the entire process and try to do my push using
git push --set-upstream origin Thunderbird_filter
and I get a 403 error every time

$ git push --set-upstream origin Thunderbird_filter
fatal: unable to access ‘https://pagure.io/forks/rlengland/fedoramagazine-images.git/’: The requested URL returned error: 403

Any help would be greatly appreciated.

1 Like

It should be /fork/, not /forks/ in that last instruction, consistent with the rest of the commands. I’ll push a fix now.

Oh. It was wrong in two places! But I fixed it.

I’m inclined to think we should remove all of the content and replace it with a pointer to the content in the docs, but there’s some advantage in having at least some of it in the repo so it’s locally available. I’ll think about that a little more.

Ben, can you point me to where these instructions are in the docs?

When I try

> git clone https://pagure.io/fork/rlengland/fedoramagazine-images

I get

> Fatal: repository 'https://pagure.io/fork/rlengland/fedoramagazine-images/' not found

When I change /fork/ to /forks/ it works for cloning

If I look at the webpage

> https://pagure.io/fork/rlengland/fedoramagazine-images

I see that /fork/ works.

If I follow the instructions through, using /forks/ when I try to push it gives me

> Fatal: unable to access 'https://pagure.io/forks/rlengland/fedoramagazine-images/': The requested URL returned error: 403

It certainly looks like there is a mismatch but I’m too much of a git neophyte to know where the problem lies.

The image creation docs are under “Contributing as an Editor”. Arguably, they should be a separate section. Historically the editors have generally made the images, so that’s probably why the instructions are there.

That is odd. I’m not sure what’s up with that. It looks like ‘forks’ is the usual path, so I’m not sure why your fork is coming up in the browser with the wrong path.

Okay, I know what the problem is here! You can’t push via https, you have to use ssh. So you can at least fix this part by changing the url in your .git/config file to use ssh://git@pagure.io instead of https://pagure.io.

But honestly I’d suggest saving your file outside of the git repo, deleting your repo and the fork on Pagure and starting over. The Git for Docs Writers documentation has good step-by-step instructions that apply just as well to the magazine-images repo.

I’m going to update the docs and the readme now to try to reduce the number of places we give instructions and simplify life a bit.

When I started through the Git for docs writers :: Fedora Docs instructions when I tried the /remote add/ step I hit another fatal error

$ git remote add origin ssh://git@pagure.io/forks/rlengland/fedoramagazine-images.git
fatal: not a git repository (or any parent up to mount point /)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).

Not critical for me right now but others might run into this.

Did you do step 3a there?

From a terminal, go to the directory you cloned above. (For example: cd $HOME/fedora/docs/quick-docs )

That error message suggests you didn’t.

I just pushed an update to the Git for docs writers page that makes it more clear that step 3b in the “before your first edit” section has to be run in the directory that you change to in step 3a. That was ambiguous before. The new docs should be reflected in the next hour or so.

And you are right, I omitted 3a. I’ve been through this too many times.

However, now I am confronted with a ssh permissions problem. I’ve reset my key via
> https://pagure.io/settings#nav-ssh-tab
but still no-go. I’ve re-checked the permissions on my .ssh and public key and the should be good.

I suggest asking for help with this in #fedora-admin on IRC or filing a ticket in the infrastructure repo.

will do. Thanks for your effort

Pagure is a beast sometimes with git newbies, myself included. I was first involved with the SIlverblue documentation and had multiple sessions with Micha Abbott on understanding git and pagure. It resulted in Silverblue moving their documentation to github!