Fcitx5 does not work for Konsole and LibreOffice


The Simplified Chinese community is inactive so I post my questions here.

I have installed fcitx5 for Chinese pinyin input, it works great in Firefox and electron-based apps, but won’t work in LibreOffice or Konsole.

I suspect it’s a problem with the Qt configurations, so here is some relevant outputs:


> $ imsettings-info                                                                                                                                                                         
Xinput file: /etc/X11/xinit/xinput.d/fcitx5.conf
GTK+ immodule: fcitx5
Qt immodule: fcitx5
XMODIFIERS: @im=fcitx5
XIM server: /usr/bin/fcitx5 -D
Preferences: /usr/bin/fcitx5-configtool 
Short Description: fcitx5
Long Description: 
Icon file: fcitx5
Is system default: TRUE
Is user default: TRUE
Is XIM server: FALSE


Hi, from your shared link to Github:

Xim server name: “fcitx5” is different from that set in the environment variable: “fcitx”.

Found unknown fcitx qt module: /lib64/qt5/plugins/kcms/kcm_fcitx5.so . Found fcitx5 im module for qt5: /lib64/qt5/plugins/platforminputcontexts/libfcitx5platforminputcontextplugin.so . Found fcitx5 qt5 module: /lib64/fcitx5/qt5/libfcitx-quickphrase-editor5.so . Cannot find fcitx5 input method module for Qt4.

First of all, I don’t know how you get ther report, but it show it’s need Qt4 version. Maybe you can search it with dnf search fcitx and you’ll find package like fcitx-qt4.x86_64. But I’m not sure if this the package you need to install.

But Konsole is definitely not an Qt4 app so I don’t think that’s the problem.

What interests me is the XIM stuff it complained about, but I did nothing other than running the configuration tools, so it’s weird.

:thinking: I tried to installed it but in Gnome.

[rizal@fedora ~]$ dnf list installed fcitx*
Installed Packages
fcitx5.x86_64                                                                              5.0.12-1.fc35                                                        @updates
fcitx5-chinese-addons.x86_64                                                               5.0.10-1.fc35                                                        @updates
fcitx5-chinese-addons-data.noarch                                                          5.0.10-1.fc35                                                        @updates
fcitx5-configtool.x86_64                                                                   5.0.10-1.fc35                                                        @updates
fcitx5-data.noarch                                                                         5.0.12-1.fc35                                                        @updates
fcitx5-gtk.x86_64                                                                          5.0.11-1.fc35                                                        @updates
fcitx5-gtk2.x86_64                                                                         5.0.11-1.fc35                                                        @updates
fcitx5-gtk3.x86_64                                                                         5.0.11-1.fc35                                                        @updates
fcitx5-gtk4.x86_64                                                                         5.0.11-1.fc35                                                        @updates
fcitx5-lua.x86_64                                                                          5.0.5-3.fc35                                                         @updates
fcitx5-qt.x86_64                                                                           5.0.9-1.fc35                                                         @updates
fcitx5-qt-libfcitx5qt5widgets.x86_64                                                       5.0.9-1.fc35                                                         @updates
fcitx5-qt-libfcitx5qtdbus.x86_64                                                           5.0.9-1.fc35                                                         @updates

From keyboard layout viewer ( fcitx5-configtool.x86_64):


Then on Konsole I use ctr + spacebar to switch the input method:


I can change the language setting in profile but when I change the encoding, the menu jump to different place.

And then trying out some command:

FYI the text in your last screenshot is garbled.

Pressing the Ctrl+Space combination have no effect in my case.

It worked after a reboot, thank you!

1 Like