Keyboard behaviour changes in gnome-terminal

Hi everybody,

my Fedora 31 install acts a bit wierd when I use gnome-terminal.
I use a teensy powered keyboard with multiple layers.
In applications like libreoffice writer, firefox, chrome etc the keyboard works like it should, the layout is the one I choose…everything is fine.
As long as I switch to gnome-terminal.
For example I got a key which outputs “|” (pipe) when pressed. In gnome-terminal this gets “converted” to a “<”.
The encoding setting in gnome-terminal is Unicode UTF-8 like it should be and a change to any other value makes no difference in behavior of my pipe key. I tried installing other terminal emulators like xfce4-terminal, tilix etc. The behave the same way.
If I leave xorg and use a tty directly the keypresses are interpreted the right way. So it seems to be a problem only connected with the graphical environment.

At the moment I have absolutely no clue why gnome-terminal changes the interpretation of the keys pressed.
But maybe someone here has an idea.


I’m sorry:

I’d read your “xfce4-terminal, tilix, etc.”. But did your tried the KDE konsole?

Just a gnome, a xfce4, and a tilix terminals are the GTK apps; konsole is QT.

Hmm, I didn’t think about that…you are right.
Tried konsole and it works just fine.
So it seems to be a GTK problem?

If I use the search bar in my gnome desktop (which should use gtk too right?) it works also.

Ok, in the “Files” file manager it doesn’t work…shouldn’ t it use GTK too?

The Gimp Tool Kit is used for all, or almost all in Gnome.
You can try KDE, there is QT, mostly.

Also, this can be a Wayland-related issue. Test it in a Xorg session, please.

In GNU Guix System, for example:
If i’m login to Sway WM as an user, and sudo -i to root, i’m get a similar wierdness with a keyboard inputs. Terminal emulator is kitty. Session is Wayland.