FC36 dnf upgrade messed up existing user settings?

I upgraded from FC34 to FC36 using dnf. I use xfce most of the time but also have Gnome installed. An existing User account (carried over from FC34) is experiencing ‘broken window management’ issues. By this I mean:

  • the xfce and gnome terminal windows have run-on menu bar items and no scroll bar (even tho it is configured for it).

  • the Pule Audio dialog is broken with much content missing (eg, I cannot control volume, etc.)

  • The ‘screenshot’ dialog window is entirely blank!

many, many other apps have dysfunctional windows

However, when I created a new User account, EVERYTHING for that new user worked perfectly fine, both under xfce and gnome.

So, somehow some cached setting for the legacy account are mangled.

I have not found info on what to do about this so am reaching out for help. I am guessing I need to delete a “.xyz” folder/file under the home directory of the legacy user account? Or is there some gnome system utility I need to update some other cached DB data for this legacy account?

Any help appreciated.


1 Like

You are correct in that the offending config appears to be under the original users home directory, and probably in one or more of the “.xyz” folder/files. We cannot tell you which one, but most of those are created after the user first logs in and uses an app. Some are named for the app they apply to.

You might consider moving all the dot files and folders in the original users home directory (found by using the l. command) to some other location then copy in all the same files from the new users home directory. You likely would not want to move the .local, .bashrc, .bash_logout, and .bash_profile, but almost everything else would be a candidate, including .config

If you just want to start clean then don’t copy in anything but start with a clean slate and let the apps rebuild it all from scratch.

I just checked, and a new user starts with only the basic dot files found in /etc/skel as a beginning. That means .mozilla is also normally there because of firefox.

1 Like

I got the answer in an email from Villy Kruse:

" This might have something to with your theme setting. Xfce used to come with a lot themes, and most of them don’t work properly after upgrading to use the gtk3 libraries. The adwaita theme works for me.

Check Settings->Appearence"

I’m now using the adwaita-dark theme and all appears to be ok.
I should have anticipated it may be theme related, but was not clever enough I guess.

thanks Jeff. Turns out it was “theme” related. See my addendum to the original post.