F36: problems with fedora-cisco-openh264

Hi there,

I’m getting an error updating with the cisco repos:
Errors during downloading metadata for repository ‘fedora-cisco-openh264’:

  • Downloading successful, but checksum doesn’t match. Calculated: 0db88912f19858ae04ce3d89ad818679f2844afc63a4cf2ead17ecfe158be012cf9fc6b233ce61563b7215cc8583f3d0c585fd7d84769eed381eea49d9c51fd6(sha512) Expected: 402d3374ade9cd9a8a35f738f1e215c1962d6aedc411524d2050d359519474f92c3826779ac518773fb44a88f0275981ec24976c7eb845dc775d146a18de1376(sha512)
    Error: Failed to download metadata for repo ‘fedora-cisco-openh264’: Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried


The file itself does not look wrong:

Is that a problem with the repo? It’s a fedora repo afterall. There is no new repo file to switch to. Is there something I can do or is this a bug worth reporting (if not already done)?

I did a dnf clean all, but that didn’t really help.

Best regards,
// STi

Did you see this ?

Or this


1 Like

It is a cisco repository, actually. For legal reasons etc.etc.

If you still have problems you can run

dnf --disablerepo=fedora-cisco-openh264 update --refresh

I believe, though, that the issue is fixed by now.

1 Like

For users, the issue is already solved: Just do sudo dnf clean all and then sudo dnf update, or directly sudo dnf update --refresh. After that, you can work as usual with sudo dnf update or whatever interface you use for updates. The error should be gone now. The unsigned packages are no longer in the updates, which is not a problem because they are not security/compatibility critical at the moment. They will be added again when the issue in general is solved. But the users do not need to care about that.

1 Like

I’m still having this error during the dnf system-upgrade download --releasever=36.

And even now, after the upgrade to Fedora 36, I still see the error if I do sudo dnf upgrade --refresh:

Fedora 36 - x86_64                                                                                                                       36 kB/s |  19 kB     00:00    
Fedora 36 openh264 (From Cisco) - x86_64                                                                                                521  B/s | 566  B     00:01    
Fedora 36 openh264 (From Cisco) - x86_64                                                                                                1.6 MB/s | 1.6 kB     00:00    
Fedora 36 openh264 (From Cisco) - x86_64                                                                                                626  B/s | 566  B     00:00    
Error: Failed to download metadata for repo 'fedora-cisco-openh264': repomd.xml GPG signature verification error: Bad GPG signature


rpm -qa --scripts  gpg-pubkey* --qf '%{Version}-%{Release}  %{Packager}\n'
38ab71f4-60242b08  Fedora (36) <fedora-36-primary@fedoraproject.org>
error: rpmdbNextIterator: skipping h#    4454 
Header V4 RSA/SHA256 Signature, key ID 38ab71f4: BAD
Header SHA256 digest: BAD (Expected 1c8858fed9ab38e3ba472b08fe88114572e6c7023ea07a96e782e61892efffa6 != 1a5d253382b1466696358f65ceff40df59b5d4f112e2983d1d585c8e6d9afaa2)
Header SHA1 digest: BAD (Expected e937bac92b11997b0f444ea1e864087744da16f1 != 4f838a2c1489972ff921530e5a822c08d788e691)

This problem above disappeared after a reboot, but not the error with repo ‘fedora-cisco-openh264’
I’m also getting another error

sudo rpm --rebuilddb
error: can't create transaction lock on /usr/lib/sysimage/rpm/.rpm.lock (Permission denied)

should I open another thread for this?

Edit 2


Regarding the main problem here, my solution/workaround is
sudo vim /etc/yum.repos.d/fedora-cisco-openh264.repo
and I set
Hence, finally:

Dependencies resolved.
 Package                                          Architecture                 Version                                Repository                                   Size
 gstreamer1-plugin-openh264                       x86_64                       1.20.3-3.fc36                          fedora-cisco-openh264                        25 k
 mozilla-openh264                                 x86_64                       2.3.1-1.fc36                           fedora-cisco-openh264                       429 k
 openh264                                         x86_64                       2.3.1-1.fc36                           fedora-cisco-openh264                       423 k

Transaction Summary
Upgrade  3 Packages

Total download size: 877 k
Is this ok [y/N]: y
Downloading Packages:
(1/3): gstreamer1-plugin-openh264-1.20.3-3.fc36.x86_64.rpm                                                                               22 kB/s |  25 kB     00:01    
(2/3): mozilla-openh264-2.3.1-1.fc36.x86_64.rpm                                                                                         302 kB/s | 429 kB     00:01    
(3/3): openh264-2.3.1-1.fc36.x86_64.rpm                                                                                                 287 kB/s | 423 kB     00:01    
Total                                                                                                                                   588 kB/s | 877 kB     00:01     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                                                                1/1 
  Upgrading        : openh264-2.3.1-1.fc36.x86_64                                                                                                                   1/6 
  Upgrading        : mozilla-openh264-2.3.1-1.fc36.x86_64                                                                                                           2/6 
  Upgrading        : gstreamer1-plugin-openh264-1.20.3-3.fc36.x86_64                                                                                                3/6 
  Cleanup          : gstreamer1-plugin-openh264-1.19.1-1.fc35.x86_64                                                                                                4/6 
  Cleanup          : mozilla-openh264-2.1.1-3.fc35.x86_64                                                                                                           5/6 
  Cleanup          : openh264-2.1.1-3.fc35.x86_64                                                                                                                   6/6 
  Running scriptlet: openh264-2.1.1-3.fc35.x86_64                                                                                                                   6/6 
  Verifying        : gstreamer1-plugin-openh264-1.20.3-3.fc36.x86_64                                                                                                1/6 
  Verifying        : gstreamer1-plugin-openh264-1.19.1-1.fc35.x86_64                                                                                                2/6 
  Verifying        : mozilla-openh264-2.3.1-1.fc36.x86_64                                                                                                           3/6 
  Verifying        : mozilla-openh264-2.1.1-3.fc35.x86_64                                                                                                           4/6 
  Verifying        : openh264-2.3.1-1.fc36.x86_64                                                                                                                   5/6 
  Verifying        : openh264-2.1.1-3.fc35.x86_64                                                                                                                   6/6 

  gstreamer1-plugin-openh264-1.20.3-3.fc36.x86_64                  mozilla-openh264-2.3.1-1.fc36.x86_64                  openh264-2.3.1-1.fc36.x86_64