F35 Headphones mono audio

After updating to Fedora 35 I’ve checked audio on my speakers and everything worked perfectly. But when I connect my headphones audio seemingly becomes mono as if there is some mixing configured. When I use GNOME Settings to check “Left” and “Right” channel they sound identical. Furthermore, I’ve used EasyEffects with StereoTools plugin to check if application itself generates mono audio, it’s not the case. I’ve never touched PulseAudio and Pipewire default config and everything worked right on F34, what could have changed?

Just to be sure, I’ve tried switching back from wireplumber to pipewire-media-session, same problem even after reboot. Then I’ve returned to wireplumber, verified that services are enabled and nothing changed

When you do the test in gnome settings does the left test sound in the left ear and the right test in the right ear? If so then stereo is working. If you were hearing mono then only one earphone would work or both would sound simultaneously.

Both test sounds come from both ears simultaneously.

Figured this out, my headphone cable broke at the same time as I updated Fedora