F32 on 160GB HDD leaves almost no free space; really?

I installed Fedora 32 from an .iso file written to a CD-R, which has a capacity of around 700 MiB. I installed it onto a hard drive with a capacity of nearly 160GiB and did it with auto-partitioning. Without adding any software, I had less than 2 MiB left on my HDD, or so it said. How is that possible? I doubt that .iso compression is that extreme. I’d like to add some software. During earlier installation attempts, when it said less than 2 MiB was left, the Blivet GUI installer told me it couldn’t install because it needed to install 5GB and so I’d have to clear space. So, I doubt the 2 MiB was only unallocated space outside of partitions.

I deleted and added some apps, including GParted. It says sda1 has about a quarter GB unused while sda2 has zero unused space. (There is no other partition.) I deleted GIMP and LibreOffice Base, which occupy about a third of a GB. No; GParted, refreshed, still says sda2 has zero unused space. Yet, I reinstalled both apps without a problem, refreshed GParted, and saw the zero hadn’t changed.

This doesn’t seem to be answered by golanv/kde-settings or Dissappearing drive space .

What’s going on?

Please paste the output of:

fpaste --sysinfo

Moderator note: 4 comments not relevant to the thread have been deleted

@matthewejacob: I’ve removed your comment here along with the replies it has received because none of them are really relevant to the thread here. They make it harder for others to follow the thread.

Please use the #site-feedback category if you wish to discuss how the forum may be improved.

1 Like


from a terminal, run

 df -h 

to find out what’s going on

1 Like

I have to take a guess, you have an LVM setup and GParted doesn’t understand LVM.


That was not possible. A CD-R has only about 700MB capacity. A DVD has 4.7GB capacity. The F32 workstattion iso has a size of ~1.9GB.
I am guessing you wrote the image to a DVD-R and not a CD-R.
The installation of F32 on a HDD generally requires at least 20GB of disk space to function and installing updates and additional packages will quickly reveal that is a bare minimum partition size.

But as to the space on your HDD, the suggestions to post the output of the commands “df -h” and “fpaste --sysinfo” will allow us to see some of the details of your system. I would add also that you should give us the output of “sudo fdisk -l”. Those 3 commands should let us see exactly what is going on.

Gparted is not lying when it says no free space. If all the space is already in partitions there is 1 MB reserved at the start of the disk and 1 MB reserved at the end of the disk for partition table and backup. Thus there would be no free space for it to use.

Also, the tools to find out why your system has no free space have to work at filesystem level not device level, so gparted is not exactly the right tool to use.


Netinstall image for Fedora 33 is 686MiB, it is probably what OP is used. The issue might be caused by Anaconda creating a small root partition when OP choose to do automatic partitioning. As mentioned befora, we need to see output of df -hT and if LVM is used sudo vgs

My error; I installed from DVD-R, not CD-R, and I wasn’t looking for netinstall; you’re right. On the DVD-R, 2.0 GB are occupied.

Maybe I’m misunderstanding free space as being space where a program (OS, app, etc.) can be installed, when it may mean only what is outside of a partition so that there can be no free space and still plenty of space for installing programs. But if that’s my error, I’m seeing that error elsewhere on the Web, including an image of a Windows dialog for properties of an NTFS drive.

I don’t have LVM or I didn’t intentionally set it up. In case I had it without knowing it, I ran lvs and got only:

  LV   VG                    Attr       LSize   Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert
  home fedora_localhost-live -wi-ao----  74.12g                                                    
  root fedora_localhost-live -wi-ao---- <69.99g                                                    
  swap fedora_localhost-live -wi-ao----  <3.92g

lvdisplay and lvscan each got the same 3, with more detail.

vgs got this:

  VG                    #PV #LV #SN Attr   VSize   VFree
  fedora_localhost-live   1   3   0 wz--n- 148.03g    0 

I interpret these results as meaning that I don’t have LVM beyond what any installation would have.

GParted doesn’t say, as far as I can tell. Maybe I’m not finding the right way to read that program. I checked Help to no avail. I’ll assume “GParted doesn’t understand LVM” is right.

df -h gave the following:

Filesystem                               Size  Used Avail Use% Mounted on
devtmpfs                                 1.9G     0  1.9G   0% /dev
tmpfs                                    1.9G   67M  1.9G   4% /dev/shm
tmpfs                                    777M  1.9M  775M   1% /run
/dev/mapper/fedora_localhost--live-root   69G   13G   53G  19% /
tmpfs                                    1.9G   48K  1.9G   1% /tmp
dev/mapper/fedora_localhost--live-home   73G  2.9G   66G   5% /home
/dev/sda1                                976M  279M  631M  31% /boot
tmpfs                                    389M  176K  388M   1% /run/user/1000

I ran fpaste just before posting this. URL: either:
https://paste.centos.org/view/52645c99 (I misunderstood the Create button at the above URL and this resulted)

fdisk -l got this (omitting blank lines before noninitial lines beginning with “Device” or “Disk”):

Disk /dev/sda: 149.05 GiB, 160041885696 bytes, 312581808 sectors
Disk model: ST9160412AS     
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x8ec5f533
Device     Boot   Start       End   Sectors  Size Id Type
/dev/sda1  *       2048   2099199   2097152    1G 83 Linux
/dev/sda2       2099200 312580095 310480896  148G 83 Linux
Disk /dev/mapper/luks-98fdc77e-7cb4-4d9e-9774-afe3881d3826: 148.03 GiB, 158949441536 bytes, 310448128 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk /dev/mapper/fedora_localhost--live-root: 69.99 GiB, 75149344768 bytes, 146776064 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk /dev/mapper/fedora_localhost--live-swap: 3.92 GiB, 4206886912 bytes, 8216576 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk /dev/zram0: 1.89 GiB, 2034237440 bytes, 496640 sectors
Units: sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk /dev/mapper/fedora_localhost--live-home: 74.13 GiB, 79591112704 bytes, 155451392 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

I don’t know what to look for to answer my question, so thank you for your analysis.

I’m not allowed to at-name more than 2 posters, so I took out all of the at-references.

This tells me it is LVM with 3 logical volumes. F32 auto partitioning uses LVM.

If you look at /boot → 631M (31%), / → 53G (19%), and /home → 66G (5%) you see plenty of free space in the system.

This was your original question.
It seems you are trying to install the OS again, so it is possible you do not understand how to do software installation under linux. It is not done from the install USB/DVD, but rather when running the OS. Maybe that was different with manjaro.

In fedora there are 2 ways to do software install.
From the command line, if you know the package name you want to install, a simple “sudo dnf install package-name” is all that is required.
If instead you want to do it through the gui the gnome software app is where you locate and install software.
Personally I use dnf all the time and not the gui because I like the flexibility and power.

I hope this solves your original question.

BTW, for readability please use code tags like this [code] data [/code] around data that is copied from command output so it is more easily readable.
This is much more readable than what you posted and the blank lines assist.

# fdisk -l
Disk /dev/sda: 223.58 GiB, 240065183744 bytes, 468877312 sectors
Disk model: SanDisk SSD PLUS
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 96C5B0E2-135F-4D02-927D-5F075A523BF2

Disk /dev/sdb: 2.73 TiB, 3000592982016 bytes, 5860533168 sectors
Disk model: WDC WD30EZRZ-00Z
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes

Disk /dev/sdc: 2.73 TiB, 3000592982016 bytes, 5860533168 sectors
Disk model: WDC WD30EZRZ-00G
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes

Disk /dev/sdd: 2.73 TiB, 3000592982016 bytes, 5860533168 sectors
Disk model: WDC WD30EZRZ-00G
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes

You can resize LV+FS from a Fedora live session.
On the other hand, you may want to install Fedora 33.
It uses Btrfs by default utilizing disk space more efficiently.


I don’t install an OS on top of an OS, unless you count that I upgraded from F32 to F33 through the normal update process. Both the Software app (gnome-software) and dnf are straightforward methods for installing apps. I almost always install apps using the Software app and almost never with dnf because I think what’s listed in Software has been vetted for compatibility with Fedora and thus is safer against apps malfunctioning because of software conflicts. I probably used blivet-gui only for diagnosis and I used it only before the latest F32 installation, since to check it this time in response to this thread I had to install it.

Autopartitioning might have added LVM only recently. If so, my past experience installing Fedora might explain why I didn’t think I had LVM active this time.

GParted, if I select a partition, lets me Manage Flags, but that menu seems not to show/hide a flag but to set/unset it. I checkmarked boot and lvm, saw what happened in the table, and uncheckmarked both to restore the original menu arrangement. A post above says, as a “guess”, that “GParted doesn’t understand LVM.” I thought of suggesting at Issues · GNOME / gparted · GitLab that GParted should provide better support for LVM but I don’t know exactly what to suggest, so I probably won’t now. If you’d like, please go ahead.

The filesystem is listed by GParted on my nonboot partition as “[Encrypted] lvm2 pv” (including brackets). Probably that was there before and I should have seen that earlier.

Looking at Disks (gnome-disk-utility) and GParted, I think “free” space is sometimes used interchangeably with “unused”, leading to confusing me. Maybe that warrants a bug report somewhere, but I’m not sure.

I’ll think about manually resizing, if I can find out how much space to add or subtract.

Yes, I think this thread answers my question. It’s still a bit complicated to sort out whether I have enough room when something says I don’t or computer behavior needs explaining, but at least I have clues. Thank you.

1 Like

If you need a graphical solution, there is a program called Blivet (execute blivet-gui), which can nicely show LVM Logical Volumes, Volume Groups, and partitions.

1 Like

The software conflicts I have experienced have always been as a result of mixing repos and not a result of dnf. I cannot speak to the idea that apps are any more vetted when downloaded through the gnome app than otherwise since with linux it is up to the user to make certain the software installed is compatible and not strictly up to the tool used (unlike windows that limits you). As long as I use only a select few repos with dnf I don’t get conflicts.

Just as an aside: I believe the gnome app uses the same repos as dnf, or at least packages come from the same.

I am not sure when auto-partitioning during install added LVM since I have been upgrading instead of new installs for several years, but I can categorically state that a clean install of F32 with auto-partitioning did use LVM for me.

I think there is some vetting by distro managers, although not of every possible combination. I once found that my disinterest in games cost me because in that distro version at that time omitting games caused some dependencies to be missing and I had to add the games back. I think adding an app can require editing a configuration file as well as setting dependencies and I’m hardly likely to have the time to take care of all that. While Fedora’s people probably do only some vetting for what goes into gnome-software, the same people can’t do any for what I pick up through dnf.

dnf uses rpm packaging and with rare exception installs all the needed dependencies for each package you install. It also keeps track of all installed packages that require a particular dependency and will not remove it as long as there is at least one requirement for it. The gnome software app also uses rpm packaging so I think your fears are quite unfounded.

In that respect dnf is far beyond the earlier precursors (rpm and yum) that often identify but do not pull in other packages as dependencies nearly as well (although they are the back ends for dnf). Yum and rpm also sometimes do exactly what you said in that they are not complex enough to keep track of all packages that have a particular dependency so it could be removed when still needed. Dnf OTOH tries to (and always has for me) prevent breaking packages that are still installed.

The rpm packaging specs handle that, and if you see a problem a bug report gets it fixed. AFAIK every package included in the fedora repositories are tested/vetted by fedora before they are included. What you install from 3rd party repos are not explicitly vetted by fedora but the rpm packaging specs keep things (mostly) compatible.

This is absolutely correct. Just to clarify: Not only do they (gnome-software and dnf) use the same repos, they also use the same mechanism for deciding what to install, how to handle dependencies, conflicts, etc.

That’s because all this is actually handled by an underlying library libdnf, which both Gnome Software and dnf call on. This means that the resulting package configuration on your system is identical regardless of whether you use Gnome Software or dnf.

I don’t think either gparted or blivet are available as FlatPaks, but it is worth noting that if one is installing FlatPaks using Gnome software, they can either be from the Fedora sources (rpms are converted to FlatPaks) but they can also be from FlatHub if the user has enabled that. FlatPaks from FlatHub are not vetted by the Fedora community—they have their own review process at FlatHub.

The only vetting Gnome Software does as far as I know is to set up the list of featured applications. Apart from that, the software listed there is not filtered in any way (as @lcts has indicated).