F32: After connecting headphones, sound continues through laptop speakers

Hi, I upgraded from Fedora 31 to 32 on my laptop (a 2015 MacBook Air) and now my headphones, Sony’s WH-100XM3, don’t work. After successfully connecting to them using Bluetooth, the sound continues to only play through the laptop’s speakers. It’s not a problem with the headphones since they still work on another device I upgraded, and the output device is switched to the headphones - in fact, changing the volume using the volume keys while the headphones are connected results in changing the headset volume, effectively resulting in the volume coming out of the laptop’s speakers to remain the same.

Any ideas?

1 Like

Sounds like a nasty bug. I am wondering with component that regressed. You need to file a bug report against the faulty component

You can install PulseAudio Volume Control (dnf install pavucontrol) which gives you much more, well, control, over which stream plays on which output. If the connection has been established and the proper device capabilities are established, pavucontrol should be able to redirect the output to your headphones, even if GNOME’s own sound settings mess up.

1 Like

Are you running Gnome? Try the extension Sound Input & Output Device Chooser by kgshank: with that you can just point&click onto where your sound should go.

That always helps me a lot since I often have my onboard soundcard, a docking station soundcard, camera sound and bluetooth connected, and the system often fails to pick the output device I need

Thanks for the responses, @alexpl’s solution worked. However, now when using a2dp, there’s terrible stuttering in my headphones that doesn’t even go away after disabling realtime scheduling.

You can give pulseaudio-module-bluetooth-freeworld from rpmfusion a try, it supports several codecs not enabled in the standard pulseaudio-module-bluetooth.

I sometimes get some stuttering when there are multiple audio sources playing, if I pause one for a while the problem goes away after a few seconds.

It’s still stuttering, and I’ve tested it with Firefox, chromium, and a local mp4 file right after reboot. Tomorrow I’ll try a live USB to rule out an upgrade problem.

Arch Linux has some excellent, up-to-date documentation that might help:


Just be careful not to try anything intended for older versions of PulseAudio or other components (it’s usually stated above each section).

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.